Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a Wikipedia editor, and I find that I can adjust the appearance of what I see by applying CSS in Preferences / Appearance.

For the fun of it I have set up a MediaWiki site on my shared hosted site, and I find that I don't have the same options in Preferences / Appearance. To be specific, on Wikipedia I see that I can do various things with regard to the Vector skin:

Vector (default | Preview | Custom CSS | Custom JavaScript)

I can choose Custom CSS and add "font-size: 1.1em;" to the Body tag and make things a bit larger for my older eyes. However, in my installation my skins are like this:

Vector (default | Preview)

I have only just set this site up a few days ago, and there's no content to speak of yet, and I have yet to learn how to do all the things I need to know, but I was surprised I couldn't set custom CSS! Is there some setting somewhere that I, as the Boss, can make custom CSS available?

share|improve this question
up vote 0 down vote accepted

OK, I tracked it down myself -- fun and games!

Anyway, this turns out to one of oodles of settings that are set in localsettings.php. I found it in the manual, believe it or not. You know, as in RTFM?

By default, this setting is false. Put it in local settings and make it true.

$wgAllowUserCss = true;

See the manual, HERE.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .