Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had this problem on my laptop for sometime now. Anytime I try to use my touchpad it works correctly about 60% of the time in Windows, the other 40% of the time, it will jump to a random spot on the screen.

It has had this problem in Windows XP, Vista, and 7! I did clean installs of each OS. Now heres where it gets weird, when I switch to Ubuntu 9.04, my touchpad works fine 100% of the time.

Is there some way I can fix this?

share|improve this question
1  
did you install the manufacturer's touchpad drivers or are you using the generic windows driver? –  Molly7244 Nov 1 '09 at 23:11
    
@Molly: Probably Windows, I'll have to check (not at my machine at the moment). I'll try that when I get home. –  Lucas McCoy Nov 1 '09 at 23:18
1  
I have the same problem, it seems to come from the Synaptics Drivers. I installed the latest from thier website and it's still doing. I'm also looking for a solution. I'm on Windows 7 and my laptop is a Lenovo N100. –  Michael B. Nov 1 '09 at 23:49
    
@Linvinloud: Try playing with the settings like ChrisF suggests. It won't stop it, but will minimize the frequency. –  Lucas McCoy Nov 2 '09 at 2:19
    
I tweaked my sensitivity in the Synaptics options, and it seems to solve the problem. –  Michael B. Nov 3 '09 at 23:50

2 Answers 2

up vote 2 down vote accepted

It sounds like an issue with the sensitivity settings of the touchpad. By that I mean how much pressure you need to exert for it to register a touch. I'm guessing that under Windows it's very sensitive & less so under Ubuntu.

Are there any settings for this in Windows? (I don't have a laptop to check myself).

share|improve this answer
    
I'm not at the machine currently but I check when I get home. –  Lucas McCoy Nov 1 '09 at 23:21
    
Well it minimized the frequency that it will jump, but it didn't totally stop it. I would say it does it 10% of the time now, which still pisses me of when it does it, but is acceptable since I only use the touchpad when traveling. So how about an accepted answer? ;-) –  Lucas McCoy Nov 2 '09 at 2:18

Linux uses entirely different drivers from the drivers on windows, so if there's a bug in the windows driver, it (likely) won't be present on Linux. But yes, check your settings for sensitivity, acceleration, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.