Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed ATI driver and I am getting the error of running in low graphic mode.

I needed to install the driver because every time I updated and upgraded Ubuntu, right after installing the packages the system runs in low graphic mode.

The answer at http://askubuntu.com/questions/141606/how-to-fix-the-system-is-running-in-low-graphics-mode-error also could not help me.

Installing fglrx also couldn't help

Graphic card model : ATI Radeon HD 3600

ATI driver is still installed and it still runs in low graphic mode.
What should I do?

share|improve this question
    
What is the output of sudo modprobe fglrx? –  SlightlyCuban Sep 5 '13 at 20:06
    
'sudo modprobe fglrx' result : FATAL: moudle fglrx not found –  sepehr Sep 6 '13 at 4:56
    
@SlightlyCuban /usr/share/ati/fglrx-install.log Package build failed! Package build utility output: ./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati- packager.sh: debclean: not found ./packages/Ubuntu/ati-packager.sh: 295: ./packages/Ubuntu/ati- packager.sh: dpkg-buildpackage: not found [Error] Generate Package - error generating package : Ubuntu/quantal –  sepehr Sep 6 '13 at 4:58

1 Answer 1

up vote 0 down vote accepted

If the performance is satisfactory you can try using the open-source "xf86-video-ati" driver. The advantage of that one is that when the kernel is updated you will have minimal issues, it'll just work. A disadvantage is that it does not perform as well in 3D applications as the closed-source fglrx driver does. Also, automatic power management (how fast the fan speed runs) is not available until Linux 3.11, which Ubuntu does not have. You can manually set the fan speed using this command:

echo low > /sys/class/drm/card0/device/power_profile

Where low can also be "mid" or "high". Low will have a quiet fan, high will run the fan at maximum speed. If you are just doing normal desktop applications, not 3D applications, then you can set low as the default on startup. Check the Ubuntu documentation for instructions on running that command on boot.

Before switching to the open-source driver absolutely make sure you uninstall the closed-source driver first, then reboot, then install the open-source one.

share|improve this answer
    
thanks . what to do with the driver which is already installed ? I can't access the desktop , don't know how to remove it ... and , where can i download and how should install "xf86-video-ati" ?? –  sepehr Sep 6 '13 at 4:29
1  
You'll need to get to a command line and purge fglrx: wiki.ubuntu.com/X/Troubleshooting/… Then you need to install the Radeon Driver: help.ubuntu.com/community/RadeonDriver And if you want help with the proprietary driver see this page: help.ubuntu.com/community/BinaryDriverHowto/ATI –  Bill Sep 6 '13 at 4:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.