Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a freecom external USB HDD, which wont run from a powered hub, so I imagined it was something to do with the powered hub not supplying enough power. However when I connect it directly to a Linux machine, and issue the command:

lsusb -v|egrep "^Bus|MaxPower"

I get the following result:

Bus 002 Device 003: ID 07ab:fc88 Freecom Technologies 
    MaxPower                2mA

(Windows Reports the same thing in fact)

Perhaps that's the power drawn by an internal hub? How can I tell how much power is really being used?

share|improve this question
    
Why don't try to determine this another way. Determine the power requirements for the device itself. You can think determine if you need a powered hub that is closer to 3MA. You also didn't indicate the watts. –  Ramhound Sep 6 '13 at 12:07
    
@Ramhound thanks for your comments. The documentation of the device does't appear to say how much power it needs. Watts=Volts*Amps, and I assuming its 5V. 2mA is obviously way to little - the drive must consume more than that. A USB 2.0 port should be able to provide 500ma. I have a 4 port powered hub with a 2000mA (i.e 2A) power supply. However I am aware some devices require more than 500mA and I suspect my drive is one such device. –  nwaltham Sep 6 '13 at 12:50
    
Provide the volts on the power supply for the hub. The best you can do is get a hub that has a 3mA power supply and test it. There should be a label on the device itself that has the power requirements, unless this isn't, a product normally sold in NA/EU –  Ramhound Sep 6 '13 at 12:57
add comment

1 Answer 1

up vote 0 down vote accepted

It looks like the device is lying to you about how much current it draws. 2mA seems several orders of magnitude too low for a bus-powered external hard drive. The MaxPower value is reported directly from the device and this wouldn't be the first time that a device manufacturer cut some corners and reported an inaccurate value.

Unfortunately there isn't a reliable way to measure the current draw of a USB device with software, which leaves only hardware solutions. If you don't care about measuring the actual current draw, and just want the device to work, I'd recommend trying a USB Y cable to see if 2 USB ports on your hub can provide enough power.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.