Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Google Earth on my Windows 8.1 preview laptop and it just hangs or crashes at the startup. Running the Windows troubleshooter says it is incompatible with Windows 8.1.

I've also tried running in compatibility mode and as an admin, but neither work.

Any ideas?

Update: Now running Windows 8.1 RTM and it doesn't work on that platform either.

Update2: I now have a new laptop which has the Intel HD display adapter and Google Earth works just fine on Windows 8.1. So I'm thinking this is only a problem with NVidia display adapters and Windows 8.1.

share|improve this question
    
If it doesn't work in compatible mode you are out of luck. It sounds like there is something specifc about the application that makes it incompatible with Windwos 8.1 Preview. I would wait until its updated and/or Windows 8.1 RTM –  Ramhound Sep 6 '13 at 18:38

5 Answers 5

I found the problem to be with Nvidia on a Lenovo Laptop T440p. In the Nvidia control panel, I set Google Earth to use the integrated graphics (Intel HD in this case) instead of the Nvidia and it starts now.

share|improve this answer
    
How do you set that when the program doesn't start? –  Bryant Mar 7 at 1:35

I upgraded to Windows 8 Pro from Windows 7 and now I've upgraded it to Windows 8.1 pro (desktop PC).

I could not get Google Earth (release 7) to work (even after all proposed cleanup / reinstalling app) with Windows 8.1.

Only found solution: Get back with Google Earth 6.2 release. Works ok so far.

share|improve this answer

Go to the Start screen.

Search for "NVIDIA Control Panel". Click on Program Settings under Manage 3D Settings.

Under Select a program to customize: click the Add button.

Go to C:\Program Files\Google\Google Earth\ and select googleearth.exe - assuming you installed x64 Google Earth if you have x64 or x32 if you have x32 Windows.

Under Select the preferred graphics processor select Integrated Graphics.

You may need to reboot to see changes.

share|improve this answer

It does work in 8.1 but most probably you have to open it with intergated graphics. Right click on the icon,choose: Run with graphics processor and than choose; Integrated graphics

share|improve this answer

To make Google earth work again on Win8

  • Go to the task manager (right click bottom left corner)

  • Choose the details tab,

  • Check the list to see if Pen_Tablet.exe is running. There are 4 Pen_Tablet files.

  • Right mouse click on each one and choose 'End Task'

Should work fine again, its because of an incompatibility with the tablet and Pen drivers and win8, on machines that don't have tablet drivers installed, they are not supported in GE anyway. you'll have to repeat this process every time you re boot unfortunately. Looking forward to a patch guys!

You may also have to right click on the google earth icon and select properties and then set the compatibility mode to win7

I had the same problem with an older version of Photoshop that doesn't support the Pen_Tablet drivers. If you are not using them, they can be stopped without any issues. They don't seem to be in the startup list, so I guess they are automatically loaded with win8.

share|improve this answer
    
Google Earth works fine in Windows 8. It doesn't work in Windows 8.1. –  Bryant Sep 16 '13 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.