Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I copied over some old files of a time machine backup on a USB drive. When I try and access a user's Desktop for example I get a "can't be opened because you don't have permission to see its contents"

How do I go about fixing that?

share|improve this question
    
You just need to change the permissions to include your user account –  50-3 Sep 7 '13 at 2:47

2 Answers 2

There is an app called BatChmod that will perform advanced permissions repairs. Of course you can also use terminal commands but this is easier in a pinch. I would start with Change ownership and privileges, Clear ACLs, and Unlock. Apply it to all subfolders obviously. http://www.lagentesoft.com/batchmod/

share|improve this answer

You have a few options.

The users files are setup in a group for that user, not you. You can:

  1. Change the owner of all the files to yourself
  2. Change the group to a group that you are a part of
  3. Add yourself to a group that has permissions to access the files to preserve permissions
  4. Modify the permissions so that anyone can read and write the files

1 will change the permissions of all the files so that you will become the owner

chown youruser:youruser ~/path/to/directory

2 will modify just the group of all the files to give you access without modifying the permissions

chown :youruser ~/path/to/directory

3 will modify your user, and add you to a group that has permissions to access the files

usermod -aG somegroup youruser

4 will change the permissions of all the files so that anyone can read / write / execute any file (not recommended)

chmod 777 ~/path/to/directory

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.