Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a document in a folder on a flash drive, and when I went to open it, it was nowhere to be found. Initially I thought it was something wrong with the USB stick where the folder was located, but when I tried to move other documents into the folder it was not possible and a In/out-error came up, saying it was impossible to move files into it, whereas in other folders it was completely fine. I can go into the folder, but it is completely empty.

So I started to think that this particular folder might have eaten my document. I also noticed an additional mysterious document I had never seen before outside of the folder, 0 byte and when it is opened, this window appears titled ASCII asking whether I want Unicode (UTF), what kind of type setting and what kind of language. I have tried to look for the document any place I could possibly imagine tmp folders, recently opened documents, but I can't find it.

Is there any way to open a larger history of recently opened documents in Libre Office in any kind of way, or is there any other way I could try to possibly recover the document?

The file system the flash drive is running on is ext3, and I tried sudo fdisk -l and then sudo fsck /dev/sdc1 but it said:

fsck from util-linux 2.19.1
fsck: fsck.ntfs: could not be found
fsck: Error 2 when fsck.ntfs ran for /dev/sda1 

I also tried fsck.vfat, could it work? Which alternative could work?

Output:
usage: fsck.vfat [-aAflrtvVwy] [-d path -d ...] [-u path -u ...]
device
-a automatically repair the file system
-A toggle Atari file system format
-d path drop that file
-f salvage unused chains to files
-l list path names
-n no-op, check non-interactively without changing
-p same as -a, for compat with other *fsck
-r interactively repair the file system
-t test for bad clusters
-u path try to undelete that (non-directory) file
-v verbose mode
-V perform a verification pass
-w write changes to disk immediately
-y same as -a, for compat with other *fsck 

Do you have any advice?

share|improve this question
    
The drive is dying. Replace it. –  user3463 Oct 3 '13 at 19:04
add comment

1 Answer

  • In the future, don't save documents directly to removable media.
  • Folders don't eat files.
  • The I/O errors are a symptom that the drive is dying.
  • If the partition is ext3 why were you trying to run fsck with parameters for ntfs and fat filesystems?

Try to recover the files using photorec

Keep in mind it will not maintain the directory structure nor the filenames (and it uses metadata to guess the file extension). Here's a step-by-step guide

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.