Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to install fedora 19 to my HDD but I get errors:

  1. you have not created a bootloader stage 1 target device
  2. sda6 must have one of the following disklabel types: GPT.

I tried:

  • Create 1-2 mb BIOS boot partition. (does not work)
  • Change UEFI to Legacy first in BIOS (USB does not boot)
  • Delete BOOTX64.efi in EFI folder in bootable USB (USB does not boot)
  • Use other USB creator - unebootin, lili usb, linux live usb creator (does not work)

Where is the problem? I've got Lenovo z500.

share|improve this question

1 Answer 1

My suspicion is that you've booted the installer in EFI mode, which requires an EFI System Partition (ESP) to be bootable. If you're partitioning manually, you should be sure to create the ESP, which is a FAT32 partition with a type code of EF00 (in gdisk, sgdisk, or cgdisk) or that has its "boot flag" set (in parted, GParted, or most other libparted-based tools). You may also need to flag the ESP as such in Anaconda, but I don't recall the details of how to do that in Anaconda's user interface. You'll need to undo the things you said you tried (except for creating a BIOS Boot Partition; that's harmless, except for the waste of disk space it represents).

share|improve this answer
    
I solved it! I used another usb. After it I changed UEFI to Legaci first in bios. Usb booted and i created 3 partitions: - 120 mb (/boot) - 4 gb (swap) - 45GB (/ fedora install) It was easy finally. But thanks for help. –  Fakt7 Sep 7 '13 at 18:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.