Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have absolutely zero desire for Firefox to have flash and any other 3rd party plugins installed for rendering web content.

Many times when I view web pages I get presented with obnoxious dialogs requesting me to install these 3rd party plugins. Is there any way to completely disable this?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Not sure about other plugins but at least for Flash

Go to about:config

Set notifyMissingFlash to False (double-click on it to toggle)

share|improve this answer
    
Marking this one as accepted as I'll be using notifyMissingFlash, i might raise it to hide_infobar if other things bug me outside of flash. –  Chris Marisic Sep 9 '13 at 14:06
add comment

For Firefox v22 or less

  1. Go to about:config
  2. Search for plugins.hide_infobar_for_missing_plugin and set its value to true.

The MozillaZine Knowledge base article on this config settings says

In Firefox, if media embedded in the page require a plugin that is not currently installed, an information bar is displayed at the top of the page allowing the user to install the required plugin. This preference will hide the information bar even if plugins are missing.

This sounds exactly like what you want to do...

For Firefox v23 or greater

The plugins.hide_infobar_for_missing_plugin config setting has been merged with plugins.notifyMissingFlash. See these bug reports on Bugzilla for more details: 869191, 870112.

  1. Go to about:config
  2. Search for plugins.notifyMissingFlash and set its value to false.

Note that from what I've read this only works for the Flash player plugin.

Alternative Option

When you get the infobar, next to the Install Flash button, there should be an arrow. If you click on this there should be an option that says Don't ask again

Firefox Missing Plugin Don't ask again

share|improve this answer
    
That entry doesn't exist in more recent versions of Firefox –  justbrowsing Sep 7 '13 at 21:35
    
@justbrowsing, What makes you think it doesn't? I'm using Firefox version 22.0 and it's listed for me when I go to about:config... –  druciferre Sep 7 '13 at 21:36
    
@justbrowsing, Never mind. I figured it out. Looks like only in the very latest version (v23) they have removed it. I updated my answer. –  druciferre Sep 7 '13 at 22:02
    
plugins.notifyMissingFlash needs to be set to false not true. And yes true for plugins.hide_infobar_for_missing_plugin –  justbrowsing Sep 7 '13 at 22:16
    
@justbrowsing, thanks! Fixed. –  druciferre Sep 7 '13 at 22:20
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.