Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was trying to format my flash USB that is a RAW format.

  • When I plug it windows asks me to format the USB I choose format I choose slow format but after 6 hours not even 1% done.
  • I tried quick format and windows says couldn't format (something like that my Windows is French).
  • I tried to format it from the command prompt format e: /X /FS:FAT32 same thing after 6 hours not even 1% done.
  • I tried quick format from the command prompt format e: /Q /FS:FAT32 but windows couldn't format.
  • I then ried with GParted; I tried to delete all the partitions and then format it. But I could not even delete partition. Trying to format without deleting partition but always same error and I tried to resize same error !

How do I fix this USB pen drive?

Will filling the disk with 0s (from a Linux shell fix it) ?
I already know it will now work becuase I already tried the latter. It wrote 1.6Mb/4Gb 0s in around 1 hour when I used dd if=/dev/zero of=/dev/sdf1. I aborted it after that hour because my sister had to use the PC.

Any solution?

share|improve this question
    
To get better performance from "dd" try add this to the end bs=32768 –  cybernard Sep 7 '13 at 23:30
    
What was the error message in GParted? Does this thumbdrive have a "physical" lock switch? –  justbrowsing Sep 7 '13 at 23:56
    
Well the erro was : LibParted Bug Found! Input/Output error during write on dev/sdf –  Strike Linux Sep 9 '13 at 9:02
    
The I/O error is a strong sign that the usb flash drive is failing/dying. –  justbrowsing Sep 9 '13 at 20:26
    
ok Thank you for your answer so you're telling me I can't fix the USB? no way to fix it? you mean throw it?? wrtiting in zeros won't fix it? –  Strike Linux Sep 10 '13 at 10:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.