Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two PC computers and I want to share files between them with a crossover Ethernet cable. I have been playing with different network configurations back and forth but I can't quite get it to work.

Computer 1

  • OS: Windows XP Pro SP2
  • Hostname: TOSH
  • Workgroup: WORKGROUP

Local Area Connection (Internet Protocol 4 properties)

  • IP: 10.0.0.1
  • Subnet mask: 255.255.255.0
  • Default gateway: none
  • Primary DNS: none
  • Secondary DNS: none

Computer 2

  • OS: Windows Vista SP2
  • Hostname: GIGA
  • Workgroup: WORKGROUP

Local Area Connection 1 (Internet Protocol 4 properties)

  • IP: 10.0.0.2
  • Subnet mask: 255.255.255.0
  • Default gateway: none
  • Primary DNS: none
  • Secondary DNS: none

Wireless Network Connection (Internet Protocol 4 properties)

  • IP: Obtain automatically (192.168.0.103 is assigned by DHCP)
  • Subnet mask: NA (255.255.255.0 in effect)
  • Default gateway: NA (192.168.0.1 is DHCP/gateway)
  • Primary DNS: Obtain automatically
  • Secondary DNS: Obtain automatically

So far so good! I can ping them both, it works in both directions. For the demonstration, here are the ping results.

Pinging Computer 1 from Computer 2:

C:\Windows\system32>ping 10.0.0.1

Pinging 10.0.0.1 with 32 bytes of data:
Reply from 10.0.0.1: bytes=32 time=1ms TTL=128
Reply from 10.0.0.1: bytes=32 time<1ms TTL=128
Reply from 10.0.0.1: bytes=32 time<1ms TTL=128
Reply from 10.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 10.0.0.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\Windows\system32>

Pinging Computer 2 from Computer 1:

C:\WINDOWS>ping 10.0.0.2

Skickar signaler till 10.0.0.2 med 32 byte data:

Svar från 10.0.0.2: byte=32 tid < 1 ms TTL=128
Svar från 10.0.0.2: byte=32 tid < 1 ms TTL=128
Svar från 10.0.0.2: byte=32 tid=1ms TTL=128
Svar från 10.0.0.2: byte=32 tid < 1 ms TTL=128

Ping-statistik för 10.0.0.2:
    Paket: Skickade = 4, mottagna = 4, Förlorade = 0 (0 %),
Ungefärligt överföringstid i millisekunder:
    Lägsta = 0 ms, Högsta = 1 ms, Medel = 0 ms

C:\WINDOWS>

Sorry about that, the XP computer is localized to Swedish. But it's self-explanatory anyway.

On Vista computer:

  • Windows Firewall is disabled.
  • There is no third-party firewall installed.
  • I can see TOSH computer if I click on Network.
  • I can view the shares and printers on TOSH.
  • I can browse Shared Documents folder and read and write files from and to this folder.

On XP computer:

  • Windows Firewall is disabled.
  • Kaspersky Internet Security is installed but protection is paused.
  • I can see GIGA computer if I click on My Network Places.
  • I can view the shares and printers on GIGA.
  • I CANNOT browse the Public folder. It results in error.

error

So you can see the error here now. Again, XP is localized to Swedish. For reference, this error message might need a translation.

\Giga\Public is not available. You might not have permission to use this resource. Ask the server administrator for help.

Access denied.

Why does it work one way but not the other? Does this have anything to do with the IP assignment? One being server, the other being a client?...

And is it possible to access all of files of an entire system disk without any restrictions, as if you were sitting by that computer? Or do you have to make shares for every single folder with files that you want to access on the other computer? Is perhaps FTP a better solution for a broader access of files?

Access on XP: I'm primarily interested in accessing these paths

  • C:\Documents and Settings\
  • C:\Program\

But having access to the entire C: drive on the XP computer would be much nicer.

Access on Vista: I want to access these paths

  • C:\Users\
  • C:\Users\Public\

I would like to access at least the Public folder. But for some reason that's not working...

Using the admin shares


As suggested in the comments, I tried using the admin shares to access the entire disk drive. I did this on both computers but it didn't work on either of them. What happens is I get an authentication dialog box asking for user name and password. But when I type in my user name and password, access is denied. It says I need to check user name and password.

I was using the user name and password of the remote computer... should I use the user name and password of the local computer (the computer I am accessing the other computer from) and maybe even have the same user name on both computers?...

On XP computer

xp1

xp2

xp3

On Vista computer

vista1

vista2

vista3

vista4

vista5

After the first attempt to log in, the "user name" input field becomes greyed out and unavailable. At this point only the password field can be changed. After the second attempt, the user name field becomes not just unavailable but also empty. At this point I have to start all over again from the Run prompt. Is this normal?...

It's different with XP. It doesn't matter how many time I type in the wrong password or how many attempts I make to access the admin share, the dialog stays put. Also, it doesn't show any errors or warnings about use of correct password like it does on Vista. The dialog just flashes and returns when the login fails.

Why is the admin share access not working? Do I have to make some change to the system first? Maybe some registry edit? Or some Group Policy edit?

Creating new share and user accounts


I have created a new share on the Vista computer.

Local path: C:\Share 1
Share name: Share 1
Network path: \\GIGA\Share 1
Group: All
Permissions: read, change

I have given full control to the group All.

share1

share1

share1

I have also created new user accounts (Testuser1) on both XP and Vista computer. I have the following users now.

XP computer users

  • Descartes (admin account)
  • Testuser1 (admin account)
  • Administratör (built-in admin account, enabled)
  • Gäst (built-in guest account, enabled, not in use)

Vista computer users

  • Sammy (admin account)
  • Testuser1 (admin account)
  • Administratör (built-in admin account, disabled)
  • Gäst (built-in guest account, enabled, not in use)

If i log in as Sammy on the Vista computer, and if I try to open \10.0.0.1\ then the Network folder opens and shares and resources of the XP computer are shown. I can open \10.0.0.1\Shared Documents, and write and read files. If I try to open \10.0.0.1\c$ I get an error. I am logged in as Descartes on the XP computer when I do this.

While logged in as Descartes on the XP computer and Sammy on the Vista computer, if I try to open \10.0.0.2\ then the My Network Places folder opens and shares and resources of the Vista computer are shown. I cannot open \10.0.0.2\Public, I get an error. Also, if I try to open \10.0.0.2\c$ I get an error.

Now that I have created the new Share 1 on the Vista computer, I tried to open it from the XP computer. When I was logged in as Descartes on the XP computer this didn't work. But when I logged in as the new Testuser1, it worked!

I will try to sum it all up here. Toshi is the XP computer, and GIGA is the Vista computer.

From GIGA to TOSHI (remote)

  • Sammy@GIGA can read and write to \10.0.0.1\Shared Documents\ with Descartes@TOSH
  • Sammy@GIGA can read and write to \10.0.0.1\Shared Documents\ with Testuser1@TOSH
  • Testuser1@GIGA can read and write to \10.0.0.1\Shared Documents\ with Descartes@TOSH
  • Testuser1@GIGA can read and write to \10.0.0.1\Shared Documents\ with Testuser1@TOSH

From TOSHI to GIGA (remote)

  • Descartes@TOSH cannot access \10.0.0.2\Public\ with Sammy@GIGA
  • Descartes@TOSH cannot access \10.0.0.2\Share 1\ with Sammy@GIGA
  • Descartes@TOSH cannot access \10.0.0.2\Public\ with Testuser1@GIGA
  • Descartes@TOSH cannot access \10.0.0.2\Share 1\ with Testuser1@GIGA
  • Testuser1@TOSH cannot access \10.0.0.2\Public\ with Sammy@GIGA
  • Testuser1@TOSH can read and write to \10.0.0.2\Share 1\ with Sammy@GIGA
  • Testuser1@TOSH cannot access \10.0.0.2\Public\ with Testuser1@GIGA
  • Testuser1@TOSH can read and write to \10.0.0.2\Share 1\ with Testuser1@GIGA

When I log in as Testuser1 on the XP (TOSHI) computer, and I try to connect to the Vista (GIGA) computer, I get the authorization dialog box. In that dialog box, I use the same credentials as for the user that's logged on to the Vista computer at the moment. So if Sammy is currently logged in on Vista computer I would use the credentials for Sammy to authorize, and so on. I'm not sure what would happen if I used the credentials for the Testuser1 on Vista (the Vista account). That would result in too many permutations for my brain to handle. I wouldn't be able to know what is what anymore. It's complicated already as it is. :)

When I log in as Descartes on the XP computer, and I try to connect to the Vista computer, don't get that authorization dialog box at all. It just jumps right in. I think it logs in automatically as I log in to Windows. It has probably something to do with that account and its configuration. This is the preferred account that I'm logged into when Windows XP loads.

On the side note, how can I close a connection without having to log out of that account? Is there a disconnect option somewhere in the My Network Places folder and the View Workgroup view?

I have only created a single new share on the Vista computer for testing. I have not tried creating a new share on the XP computer and try to access it from the Vista computer. I just assume it will work, because I can already access the Shared Documents folder from the Vista computer. If I can access this one I believe I can access any share on the XP computer from the Vista computer. It's an assumption, but a qualified assumption, given what I already know.

share|improve this question
1  
There is a hidden share that you can access by typing \\computer\c$ that will let you have access to the C drive –  Darius Sep 7 '13 at 23:31
    
If you want to share the entire C drive, just share the whole hard drive, and it can recursively apply the permissions you select to every subdirectory. Obviously be careful not to leave it open to the outside world... –  Neil Neyman Sep 7 '13 at 23:42
    
also, try start \\10.0.0.1 and if that works then, as many have mentioned append \c$ to it. I think c$ is called the admin share. you can access any drive/partition. if there's an h one then h%. –  barlop Sep 8 '13 at 1:48
    
@Darius When I type in \\10.0.0.1\c$ in the Run prompt of Vista and press Enter (in order to access C: drive on XP) I get an authentication dialog box. It asks for user name and password. I have two accounts, one is my own admin user account and the other is the administrator account. Which one do I need to use? I tried both but can't get access. –  sammyg Sep 8 '13 at 10:26
1  
The Xp machine can try at command prompt net share if you don't see c$ listed then type net share c$=c:\ –  Neil Neyman Sep 8 '13 at 19:53

3 Answers 3

You could simply share out the C: on both machines, set the Share permissions to Everyone > Full Control and the NTFS permissions to Everyone > Full Control and ANONYMOUS LOGON > Full Control

Clearly not secure, but you would be able to read/write files without the complications.

share|improve this answer

I've rather a very simple solution for you.
As you have already placed both the cumputers (1 and 2) in same network, now you may simply go to "My Network Places" of computer1 and look for the computer2.
Then place, the data you need to share, in the public folder of computer2.
Now, go to the computer2 and check for the content in its public folder.
Proceding forth the next step will be to share the other folders and you will be directly able to access it (instade of going to 'public' folder).

share|improve this answer

This is the simplest way I know of to do it (assuming no security software or firewall is obstructing:

From TOSH, use the command

NET USE T: \\GIGA\C$ /persistent:no

Now you will be asked for credentials. You must use adminstrator credentials from GIGA, NOT from TOSH.

That should be all it takes. If you can't remember the admin login on GIGA but it's already logged in, you could alternatively create a new administrator login (doesn't have to use the name "administrator" to have admin rights, of course.)

To then browse the drive, just go to T:

Note that there are issues in trying to create a share at the root level of a drive (i.e. C$) but the admin share exists by default.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.