Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So a looong time ago I tried some partitioning but I did some partitioning of my file disk (E:\) which I didn't like, so I removed the partitions I made and resized the original partition back to the full disk space. I kept a small bit of unallocated space which I couldn't add to the partition, I don't know why.

Now I'd like to add that bit of unallocated space to the actual partition using EaseUS Partition Manager (the program I used to remove the earlier partitions about a year back), but it doesn't want to add the remaining 7.8MB to the partition.

How do I fix this?

EaseUS Partition Manager // Resize/Move partition

I cannot seem to remove the number 7,8 nor drag the allocated partition (E:) to the beginning of the file. I already tried making the unallocated space bigger by shrinking the partition, but once I added it back to the partition, the 7,8MB remained unallocated.

share|improve this question
    
Have you tried doing this outside of Windows with your partition tool's boot disk? It's possible, for whatever reason, that this partition is locked while Windows is running. –  ϺОŞΣŞ Sep 8 '13 at 2:25
    
Sounds like the problem is because your partition type is MBR. –  Ramhound Sep 8 '13 at 2:40
    
@Ramhound As far as I'm aware, all my disks are MBR (I've got 3 in my system) and even my external USB3 drive. Other disks don't have this problem. –  Jochem Kuijpers Sep 8 '13 at 9:29
    
@moses EaseUS Partition Manager does a reboot and runs it's tasks before booting into Windows, requiring a reboot first. So I think that is 'outside of Windows' right? –  Jochem Kuijpers Sep 8 '13 at 9:30

1 Answer 1

up vote 1 down vote accepted

Don't worry about it.

The unallocated space appears before the partition. This means that adding that space to the partition will require moving the start of the partition, which in turn means that it will have to move a lot of the partition's data structures. This type of operation is time-consuming and risky -- a power failure, system crash, cat stepping on the keyboard, etc., can all interrupt the process and cause catastrophic data loss. The amount of unallocated space in question is 0.00082% of your total disk space; or put another way, it's about 5.4 3.5-inch floppy disks' worth of capacity. In other words, it's trivial. I understand that this sort of thing seems non-optimal and can bring out even normal peoples' obsessive-compulsive sides, but it's best to not take the risk. Granted, the risk is small, but the hassle on those rare occasions when a problem occurs is huge, so it's not worth taking that small risk. (Even if you've got good backups, do you really want to spend the time restoring your backup?)

share|improve this answer
1  
Yeah, I figured it was too small to worry about, but still I'd like to know why this is happening :) –  Jochem Kuijpers Sep 8 '13 at 9:31
    
The E:\ drive apparently was 'logical' instead of 'primary'. Allocating the 7.8MB made it a 'primary' partition. After converting the E:\ drive to 'primary' I was able to merge the two partitions and thus solve my problem. I marked this as answer because of your effort. –  Jochem Kuijpers Sep 8 '13 at 12:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.