Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to (clean) install Windows 7 64bit, but after "Copying Installation files", about 65% i got the following error: "0x80070570: Windows cannot install required files error..." . i found some description about this poblem,so I tried different things like:

  • changing memory modules, or using just one slot
  • using different installation media
  • after the failure try again from the "Install now" screen

but none of them worked. I downloaded windows 8 64 bit msdn and i got this error again. So I dont have any idea what's wrong.

Configuration: - Intel Core2Duo E6550 - Gigabyte motherboard with Intel G31 chipset - 2 x Corsair 2GB DDR2 @800MHz

Should i change something in BIOS? Any Suggestions? Thank you.

PS: 32 bit installation works fine.

share|improve this question
    
There should be no reason to fiddle with the BIOS settings. However a reset to default value and then changing the boot order and disk controller modes rarely hurts. (Make sure to select AHCI). Other thing you can try: 1) Check the install DVD. No dirt? Good download? 2) Try to install from USB pendrive (a 4+ GB stick is required) or from another DVDdrive. 3) Dumb, but reported to have worked: Simply try again. Not sure why this would work but some folks reported success this way. It seem flaky though and I wonder if they got unstable systems. – Hennes Sep 8 '13 at 12:28
    
I was trying from usb many times. Original MSDN iso(win7 and win 8 also). Tried to reset bios. (Not HDD failure, because 32 bit installation works fine, form the same iso). Still not working – stratever Sep 8 '13 at 12:46

Error 0x80070570 means a file is corrupt:

D:\>err 0x80070570
# as an HRESULT: Severity: FAILURE (1), FACILITY_WIN32 (0x7), Code 0x570
# for hex 0x570 / decimal 1392
  ERROR_FILE_CORRUPT                                             winerror.h
# The file or directory is corrupted and unreadable.
# 1 matches found for "0x80070570"

Download the ISO again and verify the hash of the ISO.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .