Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Apache-2.4.x running on a GNU/Linux system (Fedora, DHCP, IP Address: 192.168.1.5). I'm able to access the index.html page by all three methods mentioned below:

  • http://localhost.localdomain or with 127.0.0.1
  • http://192.168.1.5 (only from the same Linux server).

I've tried the following:

  1. Port forwarding (http port 80) on the Router.
  2. Tried updating iptables of the Linux server (where Apache webserver is running), now it reads as below:

     # Generated by iptables-save v1.4.3.1 on Sun Sept 08 08:13:56 2013
     *filter
     :INPUT ACCEPT [0:0]
     :FORWARD ACCEPT [0:0]
     :OUTPUT ACCEPT [33:3928]
     -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
     -A INPUT -p icmp -j ACCEPT
     -A INPUT -i lo -j ACCEPT
     -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT
     -A INPUT -j REJECT --reject-with icmp-host-prohibited
     -A INPUT -p tcp -m state --state NEW -m tcp --dport 80 -j ACCEPT
     -A INPUT -p tcp -m tcp --dport 80 -j ACCEPT
     -A FORWARD -j REJECT --reject-with icmp-host-prohibited
     COMMIT
     # Completed on Sun Sept 08 08:13:56 2013
    

NOTE: I can login to the Linux server using PuTTY. Can ping it, traceroute it from other systems in my home Network. But I'm not able to see the webpages hosted on Linux Server.

Also, I've tried looking into Apache's config file (httpd.conf), currently made Listen tag:

Listen 0.0.0.0:80
share|improve this question

migrated from serverfault.com Sep 8 '13 at 14:45

This question came from our site for professional system and network administrators.

    
nmap -p 80 <webserver public ip> can you please check with this. –  Renju Chandran chingath Sep 9 '13 at 5:49
    
code nmap -p 80 192.168.1.6 Starting Nmap 6.40 ( nmap.org ) at 2013-09-09 11:59 India Standard Time Nmap scan report for 192.168.1.6 Host is up (0.031s latency). PORT STATE SERVICE 80/tcp filtered http MAC Address: 00:0B:81:89:6F:85 (Kaparel) Nmap done: 1 IP address (1 host up) scanned in 34.97 seconds code –  TheNewJunkie Sep 9 '13 at 6:49
    
Sorry, I am trying multiple edits as I am yet understanding the various formatting on this website. I want to access my Home server from different systems in my Home network, I am not planning to open my home server to the Rest of the world. I am able to access the server at SSH port (putty connects with no issue), However not able to connect to my Apache webserver from other systems (I am able to access the Apache webserver through browser only on the same server) –  TheNewJunkie Sep 9 '13 at 6:55
    
can you please double check your firewall setting or try disabling it for a while to check it.also what error you are getting when you try to access your website? –  Renju Chandran chingath Sep 9 '13 at 7:32
    
Do let me know where shall I check, I have ran out of Ideas. I mean this is such a simple thing, which is making me break my head :-) –  TheNewJunkie Sep 9 '13 at 7:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.