Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I switch network mode to NAT mode, there's no options regarding Promiscous Mode anymore.

So VirtualBox explicitly doesn't allow it. Why is that?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

"Promiscuous mode" means the VM is allowed to receive Ethernet packets sent to different MAC addresses than its own.

In "NAT" mode, each VM is behind a virtual router that performs IP address translation in pretty much the same way home routers/gateways with NAT do – as a side effect it rejects any incoming packets unless they belong to a connection already established by the VM.

This means that the VM will never receive packets sent to other Ethernet addresses because 100% of them would be discarded by the NAT, so the promisc option would be ineffective anyway.

share|improve this answer
    
If I understand this correctly, in NAT mode each VM is separated, althrough it has IP address in the same sub network, right? –  warl0ck Sep 9 '13 at 9:31
    
@warl0ck: Yes. Each VM is behind its own NAT gateway, and even though all of them use the same IP address range, they still cannot see each other because of two NATs between every VM. It is similar to several customers of the same ISP, each behind their own NAT gateway, each using 192.168.1.0/24, but none of them seeing each other directly. –  grawity Sep 9 '13 at 10:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.