Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a Dell Inspiron 660 desktop that I had taken the hard disk from to put in my new rig. I recently put a blank hard disk in the Inspiron and am trying to boot Windows 7 on it from USB, but I'm running into some issues. (Note that the USB boot drive comes from a friend who has used it countless times without issue on his own systems)

First attempts to boot up returned a "No Boot Device" error. From there we've tried changing settings in the F2 menu (changing device priority, enabling legacy mode, etc) to no avail, although disabling Secure Boot has the unintended effect of rendering the computer completely unresponsive on power up (blank screen, no dell logo or any keyboard response) until the BIOS are reset by removing the battery on the motherboard.

The Owners manual (http://www.manualslib.com/manual/418636/Dell-Inspiron-660.html?page=101#manual) speaks of options on the F12 menu that just aren't there (the Boot Device Menu from which I am supposedly able to select the USB for boot up).

It seems that most resources instruct one to disable Secure Boot and enable legacy, but for some reason disabling Secure Boot leaves me unable to do anything else at all. What am I missing here?

share|improve this question
add comment

1 Answer

When you press the F2 key to enter the CMOS Setup options, you should find a section which allows you to make devices bootable, or disable them to prevent them from booting. SEE PAGE 92 for instructions on how to make changes to the default settings. IT IS VITAL that you understand how to do this; take your time and learn how to change the settings.

The FIRST step I'd recommend is to be SURE that ALL of the USB ports are enabled; see page 96 in the manual for specific instructions on how to do that.

Next, be sure to ENABLE "USB Boot Support"; see page 97 for instructions. NOTE that USB booting is DISABLED by default; you need to change that.

Check the "Boot Mode" settings which follow; there should be a way to make the USB devices the FIRST boot option. Although the manual doesn't specify that, the Setup page should provide instructions. Once you've set the system to boot from USB devices FIRST, you should DISABLE all other boot devices.

After that has been accomplished, you should be able to save the new settings and exit the CMOS Setup; see page 99 for more information.

When all is said and done, remember to re-enter the Setup and UNDO the changes you made. Put everything back the way it was so the system will boot from the HDD and not look for attached USB devices to boot from.

Best of luck with this; hope this helps to point you in the right direction.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.