Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As my title says, I want to connect from a Windows workstation to multiple shares on multiple FQDNs on the same IP with a different FQDN (Windows workstation or server).

Of course I know about the hosts file and set up the needed redirect. But Windows prevents me to connect to Shares with multiple FQDNs.

Example:

  1. Workstation has the IP 192.168.1.123 and the DNS name testworkstation1.nonsense.com

  2. 192.168.1.123 wants to access the following network shares on 192.168.1.234 with the following FQDNs: \\testdomain.test1.testing.com\share1 and \\thisisatest.bla.notest.com\share2.

  3. I configure my hosts file to redirect testdomain.test1.testing.com to 192.168.1.234 and redirect thisisatest.bla.notest.com to 192.168.1.234.

  4. Till now it makes sense, but now comes the problem: Windows (on 192.168.1.234) seems to prevent access to other hostnames than workstation1.companyenvironment.com. But I need to access it as testdomain.test1.testing.com and thisisatest.bla.notest.com too.

My question now: Is there a registry hack or a policy I can set to make this possible? I tought I've read something like this, but I can't find it anymmore.

share|improve this question
    
What actually happens when you try? Do you get an error message? What is it? Can you ping it by the added host names? Can you access the target PC/share by IP address? Have you ensured no firewalls or anti-virus suites are blocking you? –  techie007 Sep 9 '13 at 14:03
    
I can't access it. I can ping the target of course without any problem on every FQDN, I can access the target by its original name and firewall/antivirus isn't a problem. It has something to do with the security of Windows. I was able to get it done a few years ago, but I can't find the information. I only remember that I had to change something in the registry. –  Andy Sep 9 '13 at 17:52
    
What actually happens when you try? Do you get an error message? What is it? Did you close all other connections to the share (net use <drive> /del) before attempting to connect other versions of it? –  techie007 Sep 9 '13 at 17:53
    
I access it directly via UNC path and don't map it to a drive. This can't be the problem. I get the message that it can't access the target path. I know the solution was to disable a verification check on the target (via registry) which checks if the target is accessed by the right FQDN. It works by IP. Only the verficiation of Windows is the problem. –  Andy Sep 9 '13 at 18:01
    
This is reproducable with every default windows installation and two servers/workstations. –  Andy Sep 9 '13 at 18:17
show 2 more comments

1 Answer

up vote 1 down vote accepted

Windows Server disallows access to shares by aliases.

On the server hosting the shared, edit the registry:

In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters, add a value DisableStrictNameChecking with a type of REG_DWORD, and set to 1.

A (much more complete) answer to this is actually already over on ServerFault as well:

More info at MS: Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name

share|improve this answer
    
Wow, thanks a lot! This seems like exactly what I was searching for. I'll try it out and will give feedback when I've tried at office. –  Andy Sep 9 '13 at 22:33
    
Thanks a lot for your great help! It worked perfectly and the linked article covers a lot details. The only thing what I wasn't able to get it done, is to do it with one machine (local shares but with different DNS names). –  Andy Sep 16 '13 at 15:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.