Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've created a ssh proxy to server by invoking this command:

ssh -p1234 -D1234 someuser@someserver

With this, I'm able to load certain pages from my firefox, however, the one who need to access that particular sites is my colleague. But, they don't have ssh akses to that server. Now, I want her to be able to access the tunnel which is opened on my laptop. How do I enable that? Because, if I set the proxy on her browser to myip:1234, it's always connection refused!.

TIA.

share|improve this question
    
Do you have any iptable/firewall rules enabled ? – secureBadshah Nov 2 '09 at 9:03
    
no, I don't have both installed. – ariefbayu Nov 2 '09 at 15:02

Due to security issues, ssh -D will only listen on lo0. You must bind to eth0. You could also listen on all NICs by giving -g flag:

ssh -g -p1234 -D1234 someuser@someserver

but remember this will let ALL people use your PC as proxy :(

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .