Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Wifi works quite unreliably on my PC with Windows 7. I have tested with two different ePCI NICs, one no name and at the moment Asus PCE-N15 11n. My Wifi router is D-Link DIR-615.

It takes quite a lot of time for Windows to connect to the Wifi, and after connecting it takes about 15 seconds until the exclamation mark is cleared. Web surfing works unreliably, it looks like quite a lot of packets are lost.

Settings on the D-Link are:

  • Channel 11 (not overlapping with other networks)
  • Mixed n/g
  • Auto 20/40 Mhz
  • SSID Visible
  • WPA2
  • TKIP & AES
  • Transmit Power: High
  • Beacon: 100
  • RTS Threshold: 2346
  • Fragmentation Threshold: 2346
  • DTIM Interval: 1
  • WLAN Partition: off
  • WMM Enable: on
  • Short GI: off

Settings on Asus:

  • 11n AdHoc: disabled
  • 802.11d: disabled
  • Bandwidth: 20/40
  • Beacon: 100
  • Preamble: Short & long
  • Roaming sensitivity: low
  • TX Power Level: Auto
  • WiFi Config: Performance
  • Wireless Mode: b/g/n

Signal quality on the PC is very good, and my Nexus 7 & HTC Desire work very well on the Wifi. Any ideas how to improve the connection?

Wifi channel is 11 and it's not overlapping with other networks.

share|improve this question
    
Had a similar problem on my mom's dell latitude... All other devices worked great over wifi except that laptop. It turned out to be the driver... Getting latest and reinstalling them solved that particular problem. –  BrianAdkins Sep 9 '13 at 20:09

1 Answer 1

Some of your settings look questionable, but I'm not sure any of these things would cause your problem:

  • If you don't have a good reason for TKIP to be enabled, disable it. There were very few devices that supported TKIP but not AES, and they're all a decade old now. Replace them. I've seen lots of buggy Wi-Fi gear that can't handle mixed TKIP+AES mode correctly. It's way better to go AES-only.
  • If you don't have a good reason why you're disallowing B (as in mixed b/g/n) mode on the AP, consider adding B back in. You want your clients to be able to fall back to B rates in situations where G and N rates don't work. Depending on how your router handles the "g/n" mode it's in right now, it might not allow your clients to do that. Setting it back to "b/g/n" mode is one way to know that it should be allowing clients to fall back to those rates when necessary.
  • If you don't have a good reason for Short GI to be disabled, enable it. It allows 802.11n devices to get a small speed boost sometimes, and there's no real downside to it unless you have really crappy 802.11n devices that don't know when not to use Short GI.
  • If you don't have a good reason for 802.11d to be disabled, enable it. Maybe the country you're in was one of the countries 802.11d was created to support.

Realize that if you're on channel 11 but in auto 20/40MHz-wide mode, you're actually on both channels 11 and 7, which means you're overlapping with channels 3-13. So, since you probably have a neighbor on one of those channels (unless you live in a rural area), you probably are overlapping with them. Also, allowing 40MHz-wide mode in 2.4GHz doesn't leave any room for Bluetooth to work, so if you have any Bluetooth devices (including things like Wii remotes), you might want to use 20MHz-only mode. It cuts your bandwidth in half compared to what it might be able to do in an interference-free environment, but it makes your Wi-Fi gear a much better neighbor for other devices using the 2.4GHz band. I wish the IEEE had never approved 40MHz operation in the 2.4GHz band, because I think it may have done more harm than good.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.