Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run a Linux Mint 15 on my Thinkpad x60 tablet. I do have what seem to be serious problems with my graphics driver though: After booting, the screen just stays black. The backlight is turned on, but nothing else can be seen.

Now, I can enter the boot manager. I have tried removing the "quiet splash" option, but I still couldn't see anything. Booting with "nomodeset" works fine, but Cinnamon then tells me that it's running in software mode, which is noticeably slow and obviously consumes a lot of cpu power.

I have a 1050x1400 px panel, if that's somehow important. Other than that, its the 6363-2AG; it was upgraded to 2 GB of RAM and a 500 GB hard drive.

Does anyone have any advice on how to get this running?

/edit

Concerning the comments: No, I've got the tablet version. Still, the Intel 950 chipset should be the same. I've now booted the "normal" mode. I have no idea how that worked... It seems that 1/10 times, the graphics driver does start as it's supposed to, I just have to keep trying. The output of the command is

linux   /boot/vmlinuz-3.8.0-19-generic root=UUID=904ba055-e257-447a-b0c8-d07da953e9fb ro   quiet splash $vt_handoff
linux   /boot/vmlinuz-3.8.0-19-generic root=UUID=904ba055-e257-447a-b0c8-d07da953e9fb ro recovery nomodeset 
linux16 /boot/memtest86+.bin
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
share|improve this question
    
Is this the machine you have? So you have an intel graphics card? Is everything working fine except the "software mode" issue or do you still need help with the grub options? Please post the output of grep -P "\tlinux" /boot/grub/grub.cfg if you do. Please edit your question to add the extra information. –  terdon Sep 9 '13 at 23:52
    
Also, if this is a new install, you should update your system to get the latest drivers. Run sudo apt-get update && sudo apt-get upgrade. –  terdon Sep 10 '13 at 0:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.