Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My installation of Eclipse, while using Java in Android projects, is changing my keyboard's layout when I write any invalid statement. For example:

public class MainActivity extends Activity {
    /**
     * Called when the activity is first created.
     */
    @Override
    public void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.main);

        ImageView iv
    }
}

When I try to complete this snippet:

ImageView iv = (ImageView) findViewById(R.id.iv_imagem);

after typing "iv", the character set in my keyboard is screwed, and instead of a QWERTY keyboard (I have Portuguese language defined, and don't have other keyboards in control panel), I end up with an AZERTY keyboard, and the auto-complete shortcut Ctrl + Space is disabled.

In Windows, other applications are is still normally in QWERTY. I thought this could be Windows shifting the keyboard's language, but I disabled those shortcuts. In other applications, everything is normal. I don't know if this is related with JDK or Eclipse, because it also happens in Java projects.

Additional Info: I use Windows 7 and Java JDK, in 64 bits. For Android, I use the ADT Bundle, not the Eclipse plugin. Reinstalled ADT and JDK, with fresh versions, today, with no effects.

Many thanks for any info

share|improve this question
    
Note, Windows shifts the keyboard input language on a per-application basis, so this still sounds like it might be something going wrong with that even though you say you have the shortcut disabled. – Darth Android Sep 10 '13 at 15:13
    
thanks. i'll try the "Microsoft Keyboard Layout Creator" (read about it here: superuser.com/questions/66561/…) to remove this per-application curse. Regards, Luis – Luis Aguiar Sep 13 '13 at 11:55
    
now it gets even weirder. i notice the shortcut in eclipse to autocomplete (Ctrl + space) also changes to the chinese keyboard. but i dont remember of ever having this installed! And the fact is, in keyboards and languages, the only one i have is portuguese (see here: furioushamster.com/docs/language_portuguese.png), both the default layout and the one created with MKLC. I dont have English or Chinese installed language or keyboards, and i'd remove if i knew how. Or at least disable them – Luis Aguiar Sep 13 '13 at 12:25

You must log in to answer this question.

Browse other questions tagged .