Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have difficulties configuring network under Mac OS X. There is two routers. Router 1 has internet and I'm connecting to this via WIFI. Router 2 has no internet, but into this router is connected a Buffalo TeraStation (NAS).

Under Windows this was configured pretty easy:

  1. Wifi connected to router 1 via automatic DHCP
  2. LAN connected to router 2 via cable with manual IP 192.168.112, sub mask 255.255.255.0, default gateway not specified (as there can not be two under one system), DNS server 192.168.1.100

With this configuration under Windows I have internet access as well as full access to NAS (TeraStation).

In Mac OS X 10.8 I can't have both internet access and access the TeraStation at the same time. If I disable the WiFi adapter, I can access (see) TeraStation. If i will change settings on LAN adapter using automatic DHCP, i will have access to TeraStation, but no internet.

share|improve this question

migrated from serverfault.com Sep 10 '13 at 18:00

This question came from our site for professional system and network administrators.

    
Do yourself a favor and scrap the 2nd router and get a proper switch. it's like using a screwdriver to hammer a nail: it'll work, but it's so much more difficult. –  gravyface Sep 10 '13 at 17:34
    
I know this would sort the problem also, but there is more reasons why i don't want to. (Location of router 1 and location of terastation) also at the times of huge data transfers router 1 would not be as fast as its now keeping things separate. –  Lucas Sep 10 '13 at 17:40
1  
To be honest, none of these reasons make any sense. Most switches can operate at/near the rated wire-speed of the device (10/100 or 10/100/1000 Gigabit switch). Adding NAT/stateful packet inspection adds overhead, which is what the router needs to do. Wrong tool for the job. Simple as that. –  gravyface Sep 10 '13 at 17:45
add comment

3 Answers 3

It looks like you have them on two different networks.

  • You need to have your main router (internet access one) as 192.168.xxx.1 (where xxx is your number, also sometimes people use the 254 end instead of the beginning end)
  • and the secondary router (with the buffalo NAS) as a switch, or as close as you can. To do this, you want to have it configured with either forward broadcasts, and/or DCHP forwarder to 192.168.xxx.1
    -basically, this router need to be on the same network, but different address. i would suggest either xxx.2 or xxx.253 depending on your preference.
  • lastly, make sure all your devices are on the right network. EVERYTHING needs to be on the 192.168.xxx.0 Subnet mask 255.255.255.0 network. or 192.168.xxx.0/24 might also be shown. Default gateway should always be 192.168.xxx.1

Try this, if it doesnt work, or you want them on different networks, then you need a router running more capable software for this task.

EDIT: sorry i accidentally clicked community wiki box

share|improve this answer
add comment

http://blog.irrashai.com/blog/2009/03/how-to-add-static-route-in-mac-os-x/

http://apple.stackexchange.com/questions/33097/how-to-change-the-default-gateway-of-a-mac-osx-machine

The above links give instructions for manually setting default gateways and static routes in osx.

It sounds like the dhcp server on the TeraStation connected router is sending a default gateway. If you could disable that field in DHCP on the router you might solve your issue across all systems.. Since it sounds like that network is actually 'unrouted' and is just a local lan.

share|improve this answer
    
Can you please provide some context for those links? This would help to prevent link rot. –  Moses Sep 10 '13 at 21:04
add comment

same problem here, but really easy to solve on osx.

my configuration:

  • wifi connect to exeternal world... network is 10.13.13.255 / 24
  • wifi configuration on mac on auto configuration
  • ethernet cable connected to an old wifi/modem/router (zyxel) that is NOT connected to phone line.. network 192.168.1.255 /24
  • ethernet configuration on mac auto "using DHCP"

what's important

set service order to have wi-fi before ethernet

in this way all connections go to wifi, but connections to 192... network go to ethernet. Your NAS is obviusly on 192

here there where pictures for explanation, 
but i do not have 10 of reputation... 
so... admins pls activate... 
or guys copy and past links on browser 
(at this time it works)

**WIFI SETTINGS**
![wifi settings][1]

**ETH SETTINGS**
![eth settings][2]

**SERVICE ORDER is here**
![service order][3]

**DRAG and DROP in right order**
![service order config][4]


  [1]: http://i.stack.imgur.com/0MGM7.png
  [2]: http://i.stack.imgur.com/VoTAZ.png
  [3]: http://i.stack.imgur.com/jstqe.png
  [4]: http://i.stack.imgur.com/xu7z4.png
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.