Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hyper-V uses the Microsoft Virtual Machine Bus Video Device as your default video driver. This is okay, but the only issue that I have with it is that the color setting is 16 bit and not 32 bit. I need 32 bit for Google Sketchup 8. The VM OS is Windows XP SP3. Is there a way beside this link here to do this? I really don't want to mess with the registry.

Also I understand that RDP will use 32 bit color and just about any resolution I want. However Sketchup still flags an warning for using the 16 bit color setting.

share|improve this question
    
SuperUsers aren't afraid of editing the registry. :) – Ƭᴇcʜιᴇ007 Sep 10 '13 at 19:58
    
@techie007 Not afraid, just would like it to be a last resort. – nate Sep 10 '13 at 20:02
    
@techie007 How do I change the video adapter to use a "Standard VGA" driver? I don't see that option under display adapters in device manager. – nate Sep 11 '13 at 13:36
  • Go into the VM and into XP's Device Manager.
  • Changed video adapter to use the "Standard VGA" driver.
  • Set colour depth to 32-bit.

The Standard VGA driver will be slower (no hardware acceleration) but it lets you get to 32-bit color depths.

That's essentially all the scripting at the link you provided does.

share|improve this answer
    
How do I change the video adapter to use a "Standard VGA" driver? I don't see that option under display adapters in device manager. – nate Sep 10 '13 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .