Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can run VirtualBox just fine, but when I run anything from the command line I get:

VBoxManage.exe: error: Failed to create the VirtualBox object!
VBoxManage.exe: error: Code CO_E_SERVER_EXEC_FAILURE (0x80080005) - Server execution failed (extended info not available)
VBoxManage.exe: error: Most likely, the VirtualBox COM server is not running or failed to start.

This is pretty new. It used to work. I honestly can't remember what changed between the time that it worked and now. This particular error happened when I tried to run one a machine headless:

vboxmanage startvm VIRTUALMACHINE --type headless

but it happens with any command line operation.

share|improve this question
    
semi duplicate of superuser.com/questions/216692/… –  PsychoData Sep 10 '13 at 22:25
    
The 2 questions have nothing to do with one another. That one is asking how to do it, this one is asking about an error I get when I do it. –  aserwin Sep 10 '13 at 22:29
2  
related question then. –  PsychoData Sep 10 '13 at 22:30

2 Answers 2

I got it working after first starting VBox as Admin and then using a prompt with elevated privileges to create the vmdk.

share|improve this answer
    
I also had to uninstall virtualbox and reinstall it, running the installer as admin. I had installed virtualbox with chocolatey before (when it did not work). –  Frank Schwieterman Apr 13 at 19:51
    
Thanks! In Windows 7 starting VirtualBox as Administrator then using an Administrator command prompt fixed the error I was getting creating a linked USB drive: howtogeek.com/187721/how-to-boot-from-a-usb-drive-in-virtualbox. –  SharpC Nov 13 at 10:21

I discovered the solution here.

You must NOT run the cmd window as an Administrator to make VBoxManage.exe function without this error.

share|improve this answer
    
This didn't work for me and failed with VBoxManage.exe: error: Cannot open the raw disk '\\.\PhysicalDrive2': VERR_FILE_NOT_FOUND as I was trying to creating a linked USB drive: howtogeek.com/187721/how-to-boot-from-a-usb-drive-in-virtualbox. @Jens answer worked though. –  SharpC Nov 13 at 10:18
    
That worked for me too with vagrant - do NOT run vagrant up as admin. –  Dan Dascalescu Dec 4 at 18:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.