Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a VMware Workstation 10.0 installation with several virtual networks including the default host-only and NAT networks.

After upgrading to Windows 8.1, the NAT network was not working. I booted an Ubuntu VM with the default network setup that was previously working, and it sat for a long time during startup saying it was waiting for the network. After it finally started up, an ifconfig showed no IP address for eth0.

How can I fix the broken network?

share|improve this question

7 Answers 7

up vote 8 down vote accepted

Had the same problem with workstation 8.0.6. I only stopped all running vm's, gone to Home-Tab, selected Virtual Network Editor and did a "Restore Default". That was all. Then when i started the vm again, i got a window asking for the new network type (home network, working place or public network) and after defining my type all worked again as before.

share|improve this answer
    
Same here with Workstation 10. No need to reinstall the whole thing. –  Axel Fontaine Oct 22 '13 at 10:25
2  
I'm using vmware player (5.0.2) which doesn't seem to have virtual network editor. do I have any choice but to reinstall? –  Andy Nov 9 '13 at 13:48

Run the VMware 10.0 installer again, and select Repair on the first screen. After it finishes the repair process, run the Virtual Network Editor and check your network settings. If you had customized any of the IP addresses on your virtual networks, you may need to redo those settings. If you had any additional custom networks, you may need to re-enter them from scratch.

If you have a complex virtual networking setup, it may be a good idea to take a screenshot or make some notes before upgrading to Windows 8.1.

share|improve this answer

I am having the same issue. To resolve it just perform a re-install of vmware and it fixes the networking adapters and that is all

share|improve this answer

A full installation is not needed. I just opened Virtual Network Editor and than clicked on Reset Defaults. This reinstalled the networks and my VM's got network again.

share|improve this answer

I found another thing that can cause these symptoms. I had installed VMware Workstation 10.0.1 after the Windows 8.1 upgrade and did not have exactly the same issue. But DHCP quit working for the virtual machine behind NAT so it had no IP. Then I found the VMware NAT Service was not running and could not be started.

The reason was: port forwarding host port collision.

I first tried Restore Default" (as recommended by Marcel Krommenhoek) and the VMware NAT service began to run again. HOORAY!

UNTIL... I added my necessary port forwarding back into the VMware NAT. BOO!

I found if you set up port forwarding in VMware NAT that includes a host port already in use* on the host, the VMware NAT service fails to restart.

In this case, Skype was the problem. It was using port 80.

It was when I added port 80 forwarding in VMware NAT that the service failed to restart.

To fix this, I turned off port 80 use in Skype with:

Tools -> Options -> 
Advanced -> Connection -> 
uncheck [ ] use port 80 and 443 for incoming connections

After that I could set up forwarding for port 80 and the VMware NAT services runs fine (and correctly forwards the port into the VM).

NOTE 1: This was only in the "Desktop" Skype which I had added to this Windows 8.1 system. Apparently the "Modern" (Metro) Skype does not do this.

NOTE 2: It sure would help if the VMware Virtual Network Editor would warn you that you are trying to use a port already in use!

Using: Windows 8.1, VMware Workstation 10.0.1, CentOS 6.5 64-bit VM running Apache with JOOMLA.

share|improve this answer

I had the same problem with VMware workstation 10 running windows 10 technical Preview Could not connect to the internet. I shut down the guest os, then under virtual network editor in VMware selected the restore defaults and then I was able to connect.

share|improve this answer
    
Welcome to SuperUser.SE. You may not have noticed, but this question was asked more than a year ago. Please refrain from responding to posts more than a year old unless there is something new to add. –  LDC3 Oct 26 at 22:50

Try this is you have AVAST Firewall...

"bridged network access is actually quite similar to ICS (two IP addresses hidden behind one interface). Hence you have to enable "Internet Sharing mode" in "Expert Settings" in the Firewall page."

Source: http://goo.gl/tvztnH

share|improve this answer
    
I think you misunderstood the question. Avast has nothing to do with this at all. –  lzam Oct 2 at 0:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.