Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a VMware Workstation 10.0 installation with several virtual networks including the default host-only and NAT networks.

After upgrading to Windows 8.1, the NAT network was not working. I booted an Ubuntu VM with the default network setup that was previously working, and it sat for a long time during startup saying it was waiting for the network. After it finally started up, an ifconfig showed no IP address for eth0.

How can I fix the broken network?

share|improve this question
1  
Check out this answer before trying the answers below, it saved me a ton of time stackoverflow.com/questions/61449/… – cchamberlain Jan 9 at 4:11
    
@cchamberlain: Thanks, that is a useful tip for anyone who is wondering how to access resources on the host computer from inside a VM. (Basically, "use the hostname or IP address of the host machine instead of localhost.) This issue was a case of broken VMware networking after a Windows upgrade, so there's no real connection between the two issues, but in case someone runs into that other problem the link will help them out. – Michael Geary Jan 9 at 4:32
1  
definitely! I've hit this answer a few times when looking for the other one now so thought I'd leave comment. – cchamberlain Jan 9 at 5:23
1  
Excellent. Glad you posted that comment; this is the kind of cross-reference that is very helpful. – Michael Geary Jan 9 at 6:22
up vote 23 down vote accepted

Had the same problem with workstation 8.0.6. I only stopped all running vm's, gone to Home-Tab, selected Virtual Network Editor and did a "Restore Default". That was all. Then when i started the vm again, i got a window asking for the new network type (home network, working place or public network) and after defining my type all worked again as before.

enter image description here

enter image description here

share|improve this answer
    
Same here with Workstation 10. No need to reinstall the whole thing. – Axel Fontaine Oct 22 '13 at 10:25
2  
I'm using vmware player (5.0.2) which doesn't seem to have virtual network editor. do I have any choice but to reinstall? – Andy Nov 9 '13 at 13:48
1  
This solved the same problem on workstation 9 after an upgrade to Windows 10. – John Sampson Aug 6 '15 at 15:12
    
Worked for me as well after an unrequested upgrade to my Windows 10 install... – Bryson S. Feb 10 at 20:53

Run the VMware 10.0 installer again, and select Repair on the first screen. After it finishes the repair process, run the Virtual Network Editor and check your network settings. If you had customized any of the IP addresses on your virtual networks, you may need to redo those settings. If you had any additional custom networks, you may need to re-enter them from scratch.

If you have a complex virtual networking setup, it may be a good idea to take a screenshot or make some notes before upgrading to Windows 8.1.

share|improve this answer
1  
Worked for me. Note: You can rerun the installer with the repair function from uninstall programs in system controls. – PiTheNumber Jul 21 at 8:54

I had a similar problem. But I use VMware Player 7 instead Workstation and Windows 8.1 like local PC and Ubuntu 10.04 like guest SO.

I resolved the problem deleting the NAT Adapter and then creating a new one.

I enter the Ubuntu VM and voila!, It works!! I assume that is the way to repair in VMware Player, since there is not the same option as in Workstation.

I hope this help you!!

share|improve this answer

How to Fix NO Bridging in VMware Workstaion on Windows 10 Host

in host machine (win 10) go to

start-->setting-->network & internet --> Ethernet --> change adapter options

right click to get properties of Ethernet adapter --> install --> add --> choose service

choose "VMware Bridge Protocol" and click ok

you should see it in the adapter setting now..

restart your VM

good luck

share|improve this answer

I found another thing that can cause these symptoms. I had installed VMware Workstation 10.0.1 after the Windows 8.1 upgrade and did not have exactly the same issue. But DHCP quit working for the virtual machine behind NAT so it had no IP. Then I found the VMware NAT Service was not running and could not be started.

The reason was: port forwarding host port collision.

I first tried Restore Default" (as recommended by Marcel Krommenhoek) and the VMware NAT service began to run again. HOORAY!

UNTIL... I added my necessary port forwarding back into the VMware NAT. BOO!

I found if you set up port forwarding in VMware NAT that includes a host port already in use* on the host, the VMware NAT service fails to restart.

In this case, Skype was the problem. It was using port 80.

It was when I added port 80 forwarding in VMware NAT that the service failed to restart.

To fix this, I turned off port 80 use in Skype with:

Tools -> Options -> 
Advanced -> Connection -> 
uncheck [ ] use port 80 and 443 for incoming connections

After that I could set up forwarding for port 80 and the VMware NAT services runs fine (and correctly forwards the port into the VM).

NOTE 1: This was only in the "Desktop" Skype which I had added to this Windows 8.1 system. Apparently the "Modern" (Metro) Skype does not do this.

NOTE 2: It sure would help if the VMware Virtual Network Editor would warn you that you are trying to use a port already in use!

Using: Windows 8.1, VMware Workstation 10.0.1, CentOS 6.5 64-bit VM running Apache with JOOMLA.

share|improve this answer

I am just dropping this here as I've spend half a day to solve this issue. I used the NAT option as well, but VMWare v12.1.0 contains a bug. This has been resolved in v12.1.1. See the topic on vmware.com

share|improve this answer

Just run VMware as administrator in Windows 8 compatibility mode and everything should work.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .