Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 and network discovery is turned off. When checking my files and folders they all say not shared, and I have password protected sharing on (have tried turning it off as well). But for some reason my computer is still accessible from any other computer on my network. I don't know what to do.

share|improve this question
3  
What do you mean by "accessible?" How are you accessing your system from others? –  ernie Sep 10 '13 at 23:44

2 Answers 2

I ended up disabling a handful of services altogether to prevent it from doing this. Windows Media Player especially was a huge culprit when it came to trying to share stuff it wasn't supposed to.

To disable them pull up the services by searching for services.msc and running it as admin, or hit ctrl-alt-del and under the services tab there will be a "Services..." button to do the same. For some reason the the latter was the only way I could get mine open right now, but usually either way should work.

Once it's up look for and disable the following services:

Media Center Expander Service
Net.Tcp Port Sharing Service
Routing and Remote Access
Windows Media Player Network Sharing Service
Windows Remote Management (WS-Management)

After that just reboot and you should be good to go.

share|improve this answer
    
this is interesting, I am wondering what happens if (instead) you turn off media sharing in Control Panel\All Control Panel Items\Network and Sharing Center\Media streaming options –  Psycogeek Sep 11 '13 at 20:29

Several options and ideas.

  1. With password-protected sharing enabled, if the comps have the same login name-password then they will not need a password to share.

  2. Check that you have pw sharing disabled for all types of networks (private, public, etc). Also disable media streaming services as mentioned by Jon.

  3. If you don't need to share in either direction then try turning off home group and changing the workgroup/domain name. All of these options will probably require a restart to take effect.

  4. Might need to look into clearing cached credentials on other machines.

  5. Another path to take would be to isolate the computer on the router-side. Depending on what settings are available to you this can be accomplished (in order of my preference) using vlan, dmz, or firewall rules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.