Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with Google search in both Chrome and Firefox, when I type a search query, it will search at http://www.google.com/cse? rather than at https://www.google.com/#q= or at https://www.google.com/search?

I've read about a similar problem and the solution here, but they don't offer the solution for Linux/Ubuntu.

as the commentator say, I'd like to explain my problem more clearly.
Someone say it happened because I've install some add ons in my browser.

Actually, when I type some words at my browsers (both) address bar, It will search by http://www.google.com/cse?. But I want it search under https://www.google.com/search? (default).

share|improve this question
    
This is kinda a borderland question, are you going to google then typing in your search or using the built in search functions in chrome and firefox? –  50-3 Sep 11 '13 at 5:15
    
In Firefox, if you go to about:config and look for keyword.URL preference - what value does it have? –  JC2k8 Sep 11 '13 at 8:53
    
@JC2k8 sorry, I'm not following, where I can get about:config sir?? –  Ahmad Azwar Anas Sep 11 '13 at 9:32
    
@AhmadAzwarAnas Just type it into the location bar and press enter. –  JC2k8 Sep 11 '13 at 10:57
    
@JC2k8 it's say http://www.google.com/cse? ..., thanks sir, you save my Firefox. d(^,^)b –  Ahmad Azwar Anas Sep 12 '13 at 1:39

4 Answers 4

Since I don't use chrome this is only a partial answer.

You can change the keyword.URL preference to your wishes, using the about:config page, as laid out in the comments. Simply change the url according to your wishes. If you're on Firefox 23 or later this preference has been removed meaning that the search bar and the location bar will use the same search provider. You can read more about the consolidation of Firefox search preferences on this Bugzilla page.

What does that mean for you? Firefox 23 ignores the keyword.URL parameter. That means that it will automatically use the search engine that you have configured in the search bar in the location bar as well.

With this move Mozilla wants you to use keywords. You can assign keywords by clicking on the down arrow next to the current search engine icon and select Manage Search Engines. For instance, you can assign g to Google. If you want to do a Google search in your location bar, simply type g your search terms here and you're using Google.

share|improve this answer
    
+1. you fix me in Firefox sir.. I use Firefox 23 as your guess. –  Ahmad Azwar Anas Sep 13 '13 at 9:33

In Chrome go to Settings > Manage Search Engines and see if you have the one you're looking for, then set it as default.

If you don't, then add it. Set whatever name and keyword you want and add this to the URL form:

http://www.google.com/#sclient=psy&hl=en&site=&source=hp&q=%s
share|improve this answer
    
believe me, I've do it more than one, there is no set as default any more. You can look the preview at the link that I've referred in Google enforced by unknown administrator –  Ahmad Azwar Anas Sep 13 '13 at 3:48

cd /etc/opt/chrome/policies/managed/ I removed file «chrome.json» in that directory and now my default search engine's Google again :)

share|improve this answer
up vote 0 down vote accepted

I've found the answer at last..

try to disable add on were registered on Start up Applications... on Ubuntu

it works for me.

NOTE: as addition solution,

do this in terminal

locate chrome.json
it will return a path

sudo nano [the path]
in my condition, it will return /etc/chromium-browser/policies/managed/chrome.json

then, change the content with this

{    
  "DefaultSearchProviderEnabled": true,    
  "DefaultSearchProviderInstantURL": "http://www.google.com/search?q={searchTerms}", 
  "DefaultSearchProviderKeyword": "google.com",    
  "DefaultSearchProviderName": "Google",    
  "DefaultSearchProviderSearchURL": "http://www.google.com/search?q={searchTerms}",  
  "DefaultSearchProviderSuggestURL": "http://www.google.com/search?q={searchTerms}" 
}

Hope Helps..

Best Regards,
Ahmad

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.