Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 8.1 Pro (RTM) 64bit and made a shortcut to a autohotkey script in shell:startup. (Alt-drag and dropped the script into there to create a shortcut)

Autohotkey is set to run as administrator, UAC is disabled (slider all the way down) and it also shows up in the startup tab in the task manager as "not measured".

Double clicking the script manually works and launches it.

I have a powershell script run from a shortcut in the startup folder as well which works, so startup items generally seem to work.

I've followed this advice but no luck.

I had the same problem under Windows 8 Pro too, but it started working for unknown reason after months of launching it manually and I do not know what made it work.
Now after installing 8.1 as a clean installation it is not working anymore.

How can I get the script to launch on login/startup again?

share|improve this question
    
moving the slider down doesn't disable UAC in Windows 8.x. Use the old task scheduler trick. –  magicandre1981 Sep 11 '13 at 18:35

1 Answer 1

Windows 8(.1) prevents apps from running "As Administrator" at startup. The only possible way is via the old task scheduler trick mentioned in magicandre1981's comment.

Update: I got a new computer at work today and while I was setting up my environment I GoogleBing'd to see if there had possibly been any new developments and discovered this cool little portable app which automates the process and works great.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.