Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When emedding graphics in Word or Publisher documents that are destined for printing or distribution as PDFs, I use EPS format because it preserves the sharpness of the images at all magnifications. It worked perfectly in Office 2010 but since I upgraded to Office 2013 recently, I have found that EPS images are not printed properly. Publisher prints the preview instead of the image, and Word doesn't print anything.

In Word 2013, when I embed an EPS file, a placeholder is shown (just as a square, not the size the image should be). When I export the Word document to PDF, the same little black square is printed where the image should be. I have tried all the options such as turning image placeholders turned on (and off again), turning compression off (and on again), and nothing seems to work. I have made sure the EPS import option is selected in the Filters/Converters section of the installation. I have Acrobat Pro installed and am printing to an "Adobe PDF" printer, i.e. I am not just saving it as PDF using Word's built-in exporter.

In Publisher 2013, when I embed an EPS file, the preview image is shown as expected. When I print, the preview image is printed in all its jaggedness. I have tried all the permutations for creating a PDF - Save As..., print to an Acrobat printer, Export, saving as PostScript and converting with Acrobat Distiller, even tried a freeware alternative to Acrobat. Nothing works.

I'm just wondering if anyone can suggest anything else I might try. I'd like to stick with 2013 mainly for the nicer interface but if I can't get over this problem I'll have to go back to 2010.

share|improve this question
    
I suspect this has to do with the built-in ability to open a PDF that now exists in Office. What version of Acrobat are you using? –  Ramhound Sep 11 '13 at 11:26
    
Why do you think that is? I am trying to create a PDF, not open one. I'm using Acrobat Pro 9.0. –  Frank H. Sep 11 '13 at 11:28
2  
One of the major features that was added in Office 2013 was the native ability to not only create a PDF but to open the PDF file within Word. Have you tried to open the PDF file within Word? The only other possible explaination is that the Adobe PDF printer that is enabled by Acrobat Pro 9.0 is no longer supported by Office 2013 and you might have to upgrade to a newer version of Acrobat. –  Ramhound Sep 11 '13 at 11:39
    
Yes I can open the PDF file in Word, but I don't see how it is relevant since what I am trying to do is create a PDF. I also downloaded a trial of Acrobat Pro XI and that doesn't fix the problem either, which leaves another possible explanation -- a pretty serious bug in how Office handles embedded EPS graphics. –  Frank H. Sep 11 '13 at 14:29
add comment

1 Answer

It is well-known that the EPS import filter in MS Office is very out-of-date (seemingly was not changed much from mid-1990) and can import only limited subset of EPS files. Official Microsoft website provides little information on it but it tells us that

The Encapsulated PostScript graphics filter (Epsimp32.flt) supports the Adobe Systems Encapsulated PostScript Specification versions 3.0 and earlier.

(refs: 1, 2). The PostScript Specification version 3.0 dates back to 1992 year when it was published by Adobe. From that time it was extended essentially. Note also that PostScript Level 3 came at the end of 1997 and one should not be confused with these things: at the time of PostScript Specification version 3.0 only PostScript Level 2 was was introduced.

Besides that one should keep in mind that MS Office works only in sRGB colorspace and probably will handle graphics in the other colorspaces (such as CMYK so much loved by Adobe) incorrectly.

As to my experience recent versions of CorelDraw and Illustrator produce EPS files compatible with MS Office (although it is necessary to turn off generation of CMYK colors and work exclusively in RGB colorspace).

If you see a placeholder instead of a figure it simply means that the EPS was not imported because the MS Office EPS import filter cannot handle this particular EPS file. One possible workaround is to import this EPS file in Illustrator or CorelDraw and then export it as EPS again. The EPS file produced in this way should be compatible with MS Office EPS import filter. You could try the same method with Inkscape although EPS files generated by Inkscape are not always compatible with MS Office. Another approach is to convert EPS to PDF using Arobat Distiller, then open it in Acrobat and export to EPS, but again EPS files produced by Acrobat are not always compatible with MS Office.

It seems that free pdftops from Poppler utilities for Windows is another option. pdftops creates MS Office compatible EPS files from PDF when is launched with -level2 -eps options:

pdftops -level2 -eps input.pdf

Note that if the PDF file contains transparent objects they will be rasterized when converting to EPS because EPS basically does not support transparency. In such cases Acrobat or Illustrator can be used to get proper EPS file without rasterization.

P.S. Here is published an interesting example of EPS file which can be imported in MS Office and is displayed incorrectly but can be printed to PostScript printers correctly.

share|improve this answer
    
I created a new EPS file in Illustrator CS6 and inserted it in Word. This worked - it showed the preview in Word and showed the EPS file in the resulting PDF. –  Frank H. Sep 26 '13 at 11:33
    
However, the problem persists in Publisher. I inserted the same EPS file in a Publisher 2013 document. The preview is displayed correctly on screen, but the preview is also shown in the final PDF instead of the actual EPS content. I inserted the same EPS file in a Publisher 2010 document and it worked perfectly. So I think the conclusion is, there's a bug in Publisher 2013. –  Frank H. Sep 26 '13 at 11:50
    
@Frank I did not work with Publisher 2013. Based on your description I suppose it is a bug. –  Alexey Popkov Sep 26 '13 at 13:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.