Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While installing Visual Studio 2012 in Windows 7 64-bit, the computer restarted (power failure), and after the install the folder "d:\Program Files (x86)\Microsoft Visual Studio 11.0" was gone. Now every time I run the installer, it starts installing and 5 seconds later I get the following message:

Setup Engine  
Access Denied  

Does anyone know how to clean everything (all directories and registry) so I can start over from the beginning?

share|improve this question
    
havent u tried running setup by run as admin? –  BlueBerry - vignesh4303 Sep 11 '13 at 13:22
    
@Vignesh4303 Yes no success I'm admin on this computer –  DouglasDC3 Sep 11 '13 at 13:23
1  
Based upon your other question, can you confirm that this issue isn't with other types of installation - can you install, for example, Winamp or WinRar? –  Dave Sep 11 '13 at 13:29
    
A power failure during an install will almost definitely leave corrupted files. Are you able to manually create the folder? You could also try something like Revo Uninstaller to remove any rogue registry entries. –  trpt4him Sep 11 '13 at 13:48
    
I finally found fixed the problem. disabled all firewall/AV software and Anti-malware software. Install continued to run installation was corrupt after this. Did an uninstall an reinstall and now everything is working –  DouglasDC3 Sep 11 '13 at 13:54

2 Answers 2

up vote 1 down vote accepted

Try this.

  1. Turn off the Antivirus temporarily.
  2. Turn off Windows Firewall.
  3. Clear %temp% folder.
  4. Gave Full control permissions to Everyone and current logged in user (Admin one) role to following paths:
    • C:\
    • C:\ProgramData
    • C:\ProgramData\Package Cache

Reference here

share|improve this answer
    
This worked just one problem don't have start menu items the folder VS2012 is empty –  DouglasDC3 Sep 11 '13 at 20:20

I have recently had a corrupted installation of Rhino SDK, which also gave a similar error. I used an application called CCLeaner to clean associated registry files. It worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.