Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to upgrade a debian squeeze system to wheezy. I've done an apt-get update && apt-get -V upgrade on squeeze, then changed my source.list to reference wheezy not squeeze.

then, apt-get update (works fine)

then,

apt-get dist-upgrade

or

aptitude full-upgrade

no matter what I try the dist-upgrade fails with the message

Could not perform immediate configuration on 'perl'

for good measure i've also tried

apt-get install perl -o APT::Immediate-Configure=0

which some bug reports mention working, but it doesn't work for me.

I've found no way to upgrade from squeeze to wheezy without the upgrade failing because of this error using either apt-get or aptitude.

Does anyone know of a work around or fix?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

According to this bug report, a possible workaround would be to first update apt itself and then run the dist-upgrade.

So, first point your sources to wheezy, then run

sudo apt-get update
sudo apt-get upgrade apt
sudo apt-get dist-upgrade

As per the OP's request, I am including the solution he found in the bug report linked to above:

You need to first add experimental to sources.list deb ftp.debian.org/debian experimental main and then do

aptitude install apt from experimental" 

It must be aptitude, apt-get failed.

share|improve this answer
    
Thanks for the tip however it didn't work for me. I get the same error. –  mark Sep 11 '13 at 18:50
    
@mark oh, did you have a look through the bug report I linked to? Another possibility would be to simply remove perl, then upgrade and then reinstall it. Make sure to only remove the perl package and not perl-base which is needed. –  terdon Sep 11 '13 at 18:55
    
Yes i did, and I've found it. You need to first add experimental to sources.list (deb ftp.debian.org/debian experimental main) and then do "aptitude install apt from experimental" (must be aptitude, apt-get failed). then it works (for me). So thanks hugely, if you update your answer with the above I'll accept it. –  mark Sep 11 '13 at 19:15
    
@mark glad you sorted it out, I've added your solution to my answer. –  terdon Sep 11 '13 at 19:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.