Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've a problem with high disk IO and cpu usage from the system process. With the performance monitor I can see that it writes and reads about 100MB/s froM "System Volume Information".

I tried to get more information on which part of "system" is doing the writing, but sysinternals process explorer only shows me the TrueCrypt threads as CPU usage, which is understandable since they have to do encryption for 100MB/s. Is there a way to drill down and see which part of system is writing the stuff to "System Volume Information" and actually creating the IO?

I checked the usual suspects, defrag and restore points are disabled anyway. I also uninstalled Crashplan and TrueImage what I used for backup that might be a reason to do stuff like this with the Shadow Copy stuff. No new software was installed recently, only a windows update two weeks ago.

Not sure how much longer my SSD can take this =)

share|improve this question
1  
Try Process Manager, also a Sysinternals tool, to see which requests your system currently has to handle. This will probably find the culprit. You could also disable System Volume Information usage altogether by disabling the restore point feature in Control Panel --> System --> Advanced --> Security. Or you could exclude the SSD from being a target for the System Volume Information folder by using the options on said control panel window. –  Zerobinary99 Sep 11 '13 at 18:13
    
The restore point feature is disabled (first thing I do after installing Windows =), I'll try Process Manager. Thanks! –  Elmar Weber Sep 11 '13 at 18:28
    
use WPT to trace this: channel9.msdn.com/Shows/Defrag-Tools/… –  magicandre1981 Sep 11 '13 at 18:30
    
Try to disable Superfetch. For doing it, right click on Computer -> Management -> Services -> disable Superfetch (and restart). And tell us if it worked or not. –  Jet Sep 11 '13 at 19:58
    
Disabled Superfetch, did not make a difference. –  Elmar Weber Sep 12 '13 at 17:15

1 Answer 1

I found this post which solved this problem for me. You essentially need to change the folder type, by Right click -> Properties -> Customize and set Optimize folder for = General Items

I also tried to reduce the size of System Volume Information by reducing the space system restore can use. It might have influenced as well, but I did notice any immediate improvements.

UPDATE: After been playing a little more arround, I have discovered that it might be due to Dropbox and other applications. I have some folders that are "watched" by Dropbox as well as other applications (Virus scan, other sync tools, etc.). In short they seem to confuse each other's monitoring with actual modifications, to the refresh the new file/folder over and over and over. Shutting down Dropbox often helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.