Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A short time ago I started to use Ubuntu on my laptop. After a while I decided to exchange my original Hard Drive for a new SSD one. Because I thought (yeah I'm dumb :-( ) that I can replace the hard drives at will I replaced the old one with the new, Created a USB-installer and installed Ubuntu on the new hard drive.

Now everything was running on the new SSD but I needed the data from my old hard drive. So, I replaced the SSD with my old hard drive and hoped to start my PC normally and backup my data. But guess what happened: It starts with the message: "Operating System not found"

So I used my USB-installer-stick and tried the option "Try Ubuntu without installing". With that option I am able to see my hard drive and navigate to /home but when I try to enter my user directory where all my important data are stored Ubuntu says "Permission denied". I tried it with sudo but Ubuntu says the same.

Any suggestions/recommendations how I could access my data in the /home/{myuser} directory?

edit:

output from mount:

/cow on / type overlayfs (rw)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
/dev/sdb1 on /cdrom type vfat (ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /rofs type squashfs (ro,noatime)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /sys/firmware/efi/efivars type efivarfs (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)
/dev/sda2 on /media/a2240960-3a4d-4b62-80fb-82f0411f6bfd type ext4 (rw,nosuid,nodev,uhelper=udisks)

And ls -l:

ubuntu@ubuntu:/media/a2240960-3a4d-4b62-80fb-82f0411f6bfd/home$ ls -l
total 4
dr-x------ 4 1000 1000 4096 Sep  3 11:03 mod

ubuntu@ubuntu:/media/a2240960-3a4d-4b62-80fb-82f0411f6bfd/home$ cd mod
bash: cd: mod: Permission denied

i didn't do anything to mount the drive until yet.

share|improve this question
2  
Please boot back into the live CD and post the output of mount and ls -l in the directory containing your $HOME. How exactly are you attempting to enter the directory? Could you post the exact command? Also please post the exact error message you get and explain how you mounted your drive. –  terdon Sep 11 '13 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.