Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm guessing my current sound card setup is cause conflicts with other software (particularly Rakarrack) and I ran the aplay -l command:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: Device [USB Sound Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Notice there are two device 0. I have already configured my USB Sound Device as the default ( at least I think so) through

pacmd set-default-sink (because sound settings wouldnt display the card in available outputs)

command and it seems to be set as default but the integrated sound card is as well. I'm trying to run Rakarrack and it keeps routing both sound and input through the laptops ingrated hardware, and i'm assuming this is the problem as I've played with a ton of options through jack/jackd/qjackctl to no avail.

How can I assign a different device number to explicitly remove a device from ever being default?

EDIT: So I tried running pacmd command:
pacmd update-sink-proplist
to change the device, subdevice, and card number to something different, but when I restarted my laptop, it all reset back to 0.

I just want to universally "hard change" all my audio to my usb, but I haven't straightened it out yet (I'm very new to Linux)

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.