Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I normally (on Windows) package up a directory into a single file with Pkzip 2.5,

pkzip25 -add -dir ...

which recursively includes subdirectories and their contents. A problem I've encountered is when subdirectories begin with a dot, e.g. .settings directory created by Eclipse; Pkzip doesn't go into those directories. I can't find anything about this in the help text or on Google; is there a way to fix this behavior?

share|improve this question
up vote 1 down vote accepted

According to the pkzip 2.5 manual, pkzip considers as hidden all names that start with a dot.

Try to add the parameter "-filetype=all", in order to process files with all file types (includes hidden).

share|improve this answer
    
It seems that parameter is only available on UNIX. – rwallace Nov 2 '09 at 14:43
    
Ah, so you're on Windows. It would be a nice catch-22 if the dot-behavior was carried over from Linux, but not its antidote! In that case, there are many other zip products (like 7-Zip) which are much newer and more efficient. – harrymc Nov 2 '09 at 16:04
    
Quite so! Yeah, I've now tested 7zip on the same scenario and it works correctly, so I'll probably start using it for this purpose. – rwallace Nov 2 '09 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .