Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I've installed a new MikroTik router with 802.11b/g/n Wi-Fi (WPA2-PSK AES). All the client computers but one had no problem connecting to it. The one is old Amilo Pro V3545 with Intel 3945ABG Wi-Fi card and Windows XP SP3 installed.

The card definitely works with this router setup, because when I booted up from a live Ubuntu OS on this computer, I had no problem connecting to the Wi-Fi.

But when I'm in Windows XP and I try to connect to the Wi-Fi network, it ends with "unable to connect error". Connecting to any other Wi-Fi from Windows XP is without any problems.

I've tried to install new drivers directly from Intel's website: Wireless_15.8.0.x32 and I tried to connect with their Wi-Fi utility - It worked for once! But when I rebooted the computer, I'm unable to connect again. I tried reinstalling the Drivers (repair and also full uninstall and install), but it won't work again. I also tried disabling and enabling the device via Device Manager. Won't help.

Here is a dump of the information from Intel troubleshooter:

#Event,Source,Time,Error Severity,Domain,User,Description
1,SupplicantPlugin,09/12/2013 15:56:19,Information,Security,SYSTEM,<State> disconnected (nd3q2p)
2,SupplicantPlugin,09/12/2013 15:56:19,Information,Security,SYSTEM,DriverOIDCB- WARNING! Ignoring set event when not associated
3,EvtEngine,09/12/2013 15:56:10,Success,EvTrace,SYSTEM,Service queue reset done.

Do you have any recommendation what else should I do?

share|improve this question
    
Will it connect with no security or possibly WEP? –  Dave M Sep 12 '13 at 14:28

1 Answer 1

up vote 0 down vote accepted

I have found the culprit!

It was a "WPA2 EAP" enabled Wi-Fi security settings on Mikrotik router, which appareantly Windows XP SP3 cannot handle. When I disabled WPA2 and I am using only "WPA2 PSK", everything works great.

Attached image should help you if you are experiencing the same problem.

Leave it as displayed here:

enter image description here

share|improve this answer
    
WPA2 EAP is typically used in Enterprise installs. It usually wants specific hardware on both sides or possibly a RADIUS server. XP should work with WPA2 EAP if all pieces are in place. –  Dave M Sep 16 '13 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.