Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a server running Windows 2003 R2 SP2. I can ping it from any computer on the network. My problem is that it acts as a file and print server, but none of the other computers on the network can access these files or printers. I've done some searching and these are the things that have been suggested and the results.

Make sure a firewall isn't blocking anything; There isn't one in place aside from Windows and it is turned off.

Check the DNS; I used nslookup with the IP Address and the server name and I got the same results, so that's not the problem. I also make sure to use the IP Address just to avoid DNS problems.

Telnet into the server from a client; I'm not sure if this worked or not. I used telnet servername 445, as the article suggested. The cmd screen cleared and left me with a flashing cursor. After about a minute I got the normal prompt on the next line. I've never used telnet before so I don't know if it worked or not, but I didn't get an explicit error message.

A general fix I've ran into before is to release the IP Address, flush the DNS, and renew the IP Address. Where I work, this seems to fix a lot of issues, but it didn't fix this one.

I've tried mapping the drives through Windows Explorer and the command prompt, but neither works. In command prompt, I get the error: Multiple connections to a server or shared resource are not allowed. In Windows Explorer, I get the error: The network path \\servername\share cannot be found. I've also tried to access the server through the run box. When I do I get the error: \\servername\share is not accessible. The network path was not found.

It is also worth mentioning, the server is experiencing a near identical problem. I can ping any computer on the network, but cannot access shares made on those computers from the server. I did this for testing purposes when the issue started, so fixing this direction of connection isn't a priority, but I feel this is relevant to the overall issue. When I try to use the run box to connect to the client's share from the server I get the error: \\clientname\share is not accessible. The network is not present or not started. The Windows Explorer and command prompt errors are the same as above.

Any and all help is greatly appreciated. Thanks in advance.

EDIT: Sorry for the single slash. I had typed two, but I guess HTML saw it as one. I had to put three for it to show two. It wouldn't let me add a comment so I just included this edit.

EDIT 2: Sorry, it still won't let me add a comment. It is part of a domain, and I'm sure that credentials aren't the issue. I've tried going in with the local and domain administrator accounts.

EDIT 3: Yes, Scott. I was at the aforementioned server when I made the question, but went back to my office afterwards. I'll see if I can find that registration email. Sorry for the trouble.

share|improve this question
One thing I notice throughout your question is that you aren't formatting UNC share paths properly. There are two backslashes at the beginning of UNC shares, not one. For instance, \servername\share is incorrect. The correct path is \\servername\share. Perhaps this was a typo but it would cause this problem. – Moses Sep 12 '13 at 19:02
Are you running the server and PCs within a domain environment, or is the former acting as a straight-up file server? If it's just a file server, are you sure you have valid credentials set up on the server so the clients can access it, and vice versa? – user253650 Sep 12 '13 at 19:42
@ZeverMX: I believe that your problem with Super User (not being able to add comments to your own question, and not being able to edit it directly) is due to the fact that you have been using two different Super User accounts. Yes, you’ve been logging in with the same e-mail address, but maybe from different machines? Your question was asked by SU user #253627, but you have been editing it as user #236491. I’m not sure how to handle this, but if you register an account, it will probably help. – Scott Sep 12 '13 at 20:27
I want to add ping is often not a good test. At best it will tell you a network interface is reachable, but that doesnt tell you anything more than the device is responding to pings. At worst, it tells you nothing, which means... well... nothing. There are countless reasons why ping can fail, even if the device is fully operational. – Keltari Nov 21 '13 at 3:10

My boss finally figured it out. Very simple fix. The Workstation service wasn't running. It was set to automatic, but never started. Everything fixed itself when that started.

share|improve this answer

I had a Win7 Home edition system that would not see or be seen from other Win7 computers on my network. Each and every system connected through router to Internet with no issues. Pinging IP addresses in either direction worked consistently, BUT pinging COMPUTER-NAME in either direction would NOT work.

Checked WORKGROUP name, DNS, router settings, Windows services. Nothing.

Started looking at less likely reasons I could think of: firewall ports, HOSTS files, LMHOSTS, ARP cache, malware, higher-level stack corruption, errant third-party apps, exorcism of evil spirits...

Driving me nuts! I used to troubleshooting for a living, now I can't get a system (with NO apparent problems) to talk to the rest of my simple network, and vice versa!

NO local system communication beyond pinging IP addresses worked. So, I knew it was likely a Windows issue, more precisely, Windows-specific networking.

I finally found the problem. I had disabled HomeGroup services manually (HomeGroup doesn't work with my young kids' old XP machines, and it is nothing an advanced user would really ever need). BUT, in spite of disabling HomeGroup services, WHEN THE COMPUTER'S ADVANCED NETWORK SETTINGS FOR 'PRIVATE NETWORK' WERE LOOKED AT, 'HOMEGROUP' WAS STILL SELECTED. Deselected it, and everything worked immediately. DOH!

My fault for being too techy and disabling the services directly instead of going through the dialog panel. I suspect an "ON" flag was still set inside the registry, even though the HomeGroup services were disabled, and this led to the older NETBIOS-type of connection from being allowed.

This parallels the old advice that, IF given a choice, ALWAYS change a registry setting via a Windows dialog panel, instead of directly through the registry. As in this instance, there are often unseen levers interacting with other components that only show up as problems later -- problems that you may not associate with a change you made earlier. (We've all been there, right?)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .