Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm sorry if this is a very basic question. I am using ssh to log on to another Windows computers. Hence I am trying to make a pssession on a localhost. But I cannot do it in normal posh prompt:

$ New-PSSession
New-PSSession : [localhost] Connecting to remote server localhost failed with the
following error message : Access is denied. For more information, see the
about_Remote_Troubleshooting Help topic.
At line:1 char:1
+ New-PSSession
+ ~~~~~~~~~~~~~
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspa
   ce) [New-PSSession], PSRemotingTransportException
    + FullyQualifiedErrorId : AccessDenied,PSSessionOpenFailed

I have to have administrator posh. Is there any way to do this without administrator privileges?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Powershell Remoting has a default PSSessionConfiguration called Microsoft.PowerShell with a SDDL which only allows people with administrative rights to execute remote commands on that machine.

You will need to get in touch with an administrator and have them open that up for you:

PS C:\> Set-PSSessionConfiguration -Name Microsoft.PowerShell -showSecurityDescriptorUI

More info here: http://blogs.msdn.com/b/powershell/archive/2009/11/23/you-don-t-have-to-be-an-administrator-to-run-remote-powershell-commands.aspx

Don't forget to Enable-PSRemoting along with opening the appropriate ports (5985 HTTP/5986 HTTPS).

share|improve this answer
    
@joon please avoid posting thank you messages, the thank you is implied when you accept an answer –  50-3 Sep 12 '13 at 20:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.