Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am attempting to disable screensaver, screen blank and screen lock via the command line. This is because the settings will be applied in an unattended install.

From my own research this appears to be possible through xorg.conf.

I have tried setting:

Section "ServerFlags"
    Option          "BlankTime" "0"
    Option          "StandbyTime" "0"
    Option          "OffTime" "0"
    Option          "SuspendTime" "0"
EndSection

Also:

Option "DPMS" "false"

in the Monitor section.

But even with these settings, when the machine is inactive for a period of time, the screen blanks and shortly after locks (password is required to disable screen blank).

Can someone please point me in the right direction?

I am running the XFCE spin of Fedora 19

share|improve this question

1 Answer 1

up vote 5 down vote accepted

You can use the xset command to disable screen blanking and locking.

E.g.

xset s off (turns off the screen saver) xset s noblank (turns off blanking)

You can also use it to disable the power management using dpms to power the monitor down

xset -dpms

I use these commands in a script set to run at login to stop the screen blanking on my MythTV machine.

EDIT:

Script I mentioned:

#!/bin/sh
export DISPLAY=:0.0
xset s off
xset s noblank
xset -dpms
share|improve this answer
    
I tried these commands, but unfortunetly, with no joy: xset -dpms xset s 0 0 xset s off xset s noblank –  dooffas Sep 13 '13 at 11:27
    
Ok, so it does appear that those commands do work, when run on the local machine not via SSH. I have these commands in a script that is loaded on boot, however again they do not seem to work. How do you have your script? –  dooffas Sep 13 '13 at 13:42
    
Ahh, yeah, the trick will be to make sure the DISPLAY var is set to :0.0 (rather than the forwarded version that ssh will set up), I'll edit the answer to add the script so it should keep the formatting –  hardillb Sep 13 '13 at 21:38
    
I have now managed to get this to work, however I had to add a sleep to the start of the script, otherwise it did not appear to have any affect. I presume this is due to the x session not being fully started before the script is run. –  dooffas Sep 16 '13 at 9:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.