Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently installed Kali Linux and am having connection issues. It says I am connected to the network, but I am not able to access the Web. A Ubuntu 13.04 running on the same machine (dual boot) works just fine. Additionally, Wireshark detects a flood of NBSTAT packets coming from my router to my machine. My network components are as follows: My modem is a Westell VersaLink 327W, and my router is a 2011 Apple Airport Express. The wireless card in my computer is an Intel Centrino Advanced-n 6205. My network is running on channel 1, does not use MAC filtering, does not have a hidden ESSID, and is using WPA2-PSK encryption. As far as I can tell, all of the components are running the correct and most up-to-date firmware.

I originally thought that the problem could lie in errors caused by both operating systems (and therefore different wireless drivers) having the same MAC address. However, this can't be true, since the computer connected successfully connected to a network at school and I was able to access the Web.

Update: Connecting via ethernet and then disconnecting temporarily (until I restart my session) fixes this problem. I have also tried using a static IP instead of DHCP to see if that was the cause of my problem. The NBSTAT packets are not showing up anymore. Now I am seeing an abundance of ARP requests (Who is at IP 192.168.1.xxx? Tell 192.168.1.254).

Update 2: I just tried to connect directly to the modem's wireless without the Apple router acting as a middleman. I am still not getting through to the internet. On a side note pinging local IPs doesn't either. This seems to be a problem with the modem.

Update 3: Replaced Westell modem with a 2WIRE from AT&T. Still no dice.

share|improve this question

1 Answer 1

When you are attempting to ping the gateway while connected wirelessly , what response are you getting from pinging the gateway address? Look to see if it's the IP address for eth0. I spent several days working on a similar issue with my lenovo laptop with a Centrino advanced-n 6205. I found out that the laptop was trying connect through the eth0 adapter even without a cable attached. I would try to disable the eth0 adapter and see if the wireless adapter connects.

share|improve this answer
    
I have attempted to ping the gateway but have received no response. I will check if it is attempting to connect through eth0. –  Cameron Kennedy Oct 2 '13 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.