Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed arch bang in my vmware workstation. The internet works fine but the pacman is not working Output of pacman -Syy :

:: Synchronizing package databases...
error: failed to update core (no servers configured for repository)
error: failed to update extra (no servers configured for repository)
error: failed to update community (no servers configured for repository)
error: failed to synchronize any databases
error: failed to init transaction (no servers configured for repository)

I am running behind a proxy with bridged network adapter. How do I make the pacman work?

share|improve this question
    
I don't have enough reputation to comment and ask you if you've uncommented any repositories in /etc/pacman.d/mirrorlist, but that looks to me like what's happening. Have you uncommented some repos in the mirrorlist file? –  mellowmaroon Sep 14 '13 at 7:04
    
No. nothing is commented or uncommented. –  sudeepdino008 Sep 14 '13 at 9:17
    
Can you please show us your mirrorlist? –  jens-na Sep 24 '13 at 13:00
add comment

1 Answer

Sorry, I have to comment through an answer again, but I'm fairly certain the problem is as I mentioned. I was able to replicate your behavior by not having any servers listed in /etc/pacman.d/mirrorlist.

First though, you said "Nothing is commented or uncommented", which doesn't make any sense to me. Your servers listed in /etc/pacman.d/mirrorlist must be either commented or uncommented. You can find details here in the Arch Linux Beginner's Guide

Assuming you have nothing at all listed in that file, you can use Arch Linux's Pacman Mirrorlist Generator, which entails the following:

  1. Using the website to generate a mirrorlist file relevant to your country of residence
  2. Uncomment any servers you want to use
  3. Move the file to /etc/pacman.d/, and maybe sudo chown root:root /etc/pacman.d/mirrorlist so nothing weird happens with permissions

I do have one question though: Why not just use Arch Linux?

share|improve this answer
1  
I have my exams coming up. My internet connection is through proxy which always makes it hard to connect to internet when it comes to arch. I tried arch linux before but always got stuck on the proxy part. Of course if I could get the pacman running in arch bang, I would surely move to arch linux. Could you tell me hw to configure the proxy settings in arch bang? –  sudeepdino008 Sep 14 '13 at 18:01
    
I did update the mirrorlist. It still doesn't work. –  sudeepdino008 Sep 14 '13 at 21:42
    
I know what you mean about the lack of time, but once you have a good amount of free time, it's worth the work, and helps you learn how to fix problems like this. Have you set the shell variable http_proxy? Like this: su && export http_proxy=http://123.45.67.89:12345/ && pacman -Syy. It looks like wget reads this variable, and you can use wget with pacman. –  mellowmaroon Sep 14 '13 at 22:02
    
Yes i did set the shell variables as told in the wiki. Should the network connection be NAT or bridged? –  sudeepdino008 Sep 15 '13 at 6:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.