Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I try to record a video with my webcam (I haven't tried, but I suppose that it won't work also for programs like Skype) I can correctly capture the video, but they are silent, the audio is not recorded. There should be some setting that need to be properly configured, but for now I haven't found it.

I'm using Kubuntu 12.04 with KDE 4.11.1; I'm using an Acer Travellmate 5720G and the webcam is integrated in my laptop's lid. I don't use the webcam very often so I can't say it for sure, but I think that it worked before the upgrade to the latest version of KDE.

Here are some screens taken from the System Settings:

enter image description here

enter image description here

enter image description here

As you can see in Audio Playback the sound card is correctly recognized, same thing for the webcam in the Video Recording section; but in the Audio Recording, nothing seems to be properly set up.

I've tried to capture the video both with Kamoso and VLC, and the problem persists, so I can exclude that it is related to one of these specific programs.


UPDATE

I've discovered that I had not selected the proper options:

enter image description here

The Analogic Stereo Output entry ws selected, so obviously the device was not set to be used also as an input. By selecting Analogic Stereo Duplex now I correctly get this:

enter image description here

Now I'm able to record audio along with video from the webcam, the problem is that the quality is very lousy. I have the following options available:

enter image description here

Line-in, surprisingly enough, is for external devices plugged in the line in jack, so obviously it's not what I'm looking for. The other two options are Microphone and Internal Microphone. If I use the former, all I can get is a continuous, regular and plain sound of static, it doesn't seem to record any sound from the surrounding environment at all. Even if I try to talk, I can't notice the slightest variation in that output noise. If I use the latter (Internal Microphone) the situation is better: I don't have any background static, and if I talk my voice is recorded, but the output sound quality is very lousy: it sounds scratched, something like a buzzing or a croaking. How can I improve it?

Please note that in both cases, adjusting the Input Volume Levels doesn't change the quality of the output.

share|improve this question
    
What do you have selected on the Recording (not Communication) entry under Audio Recording? –  terdon Sep 14 '13 at 16:00
    
Nothing, because nothing is selectable. There I have only the "internal analogic stereo audio" entry, but it's greyed out and not selectable. –  Sekhemty Sep 15 '13 at 20:25

1 Answer 1

Had similar issues on different computers and different OS's (Ubuntu 12.04, 13.04, 13.10). Installing PulseAudio Volume Control (pavucontrol) did the trick for me. Can't post images, though you might want to try one of the suggestions on following site: record internal sound

share|improve this answer
    
I'm using Kubuntu, it has a KDE graphic environment with all its own configuration modules; that package will install a GTK configuration GUI, but in itself will not help me to solve my problem, I need to properly configure some settings, not to have another GUI for those settings. Anyway, thanks for the suggestion. –  Sekhemty Sep 20 '13 at 12:12
    
You're welcome. However pavucontrol seems to offer more control over your settings and there seems to be a KDE version of it as well (use the Muon Package Manager). Here's a youtube video of how it's done: link –  Frank Sep 20 '13 at 12:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.