Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on Windows7 64-bit SP1 up to date w/ an AMD Turion II 540 Dual Core processor (x64). I have 4GB of RAM

I am using VMWare Workstation 9 and created a new VM running XP3 Professional 32-bit from an ISO. The problem I am having is that I cannot get Windows update to work on the XP3 install. W/U works fine on my host machine. I have tried the following so far:

  1. Downloaded and installed the latest version of Microsoft/windows update from the Microsoft Download center
  2. Running the Windows Update Fix-it utility on Microsoft's site(it said it fixed the problem of the location where update files are stored had been moved)
  3. using C:\WindowsUpdateAgent30-x86.exe /wuforce (on the file downloaded)
  4. I created a new VM to see if the install was corrupt, but had the same issue.
  5. I also tried going directly to the micrsoft update website, and it just checks forever and never gives an error message(I have waited 30+ minutes). IE 6 locks up at this point and I have to force shutdown.

How can I fix this?

I am also getting the error after the installation that the VM disk has become defragmented. I allowed 50GB of HD space for this VM.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.