Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem where Mint updated my system,and also changed my grub2 entries. It needed to do this.. but in changing grub entries it REMOVED my Windows on /dev/sda1 entry.

I can still see the partition being present if I check with "disks" tool from the menu but I cannot get the vital information of the UUID. Now I cannot even attempt to add a new windows entry in grub.

Any tips?
I tried blkid, which does not give me sda1 info.
I tried vol_id but not present on mint

I figure that as soon as I have the UUID, at least I can attempt a restoration.

share|improve this question

1 Answer 1

You can get his done by a simple command:

ls -l /dev/disk/by-uuid

this should work flawlessly, since ls is a core functionality.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.