Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to curl ipv6 adresses, but without success.

If i try lets say:


I wait for a timeout and get network unreachable

If i force ipv4, everything is fine.

curl -4

Then again if i force ipv6, like this:

curl -6

i get:

curl: (7) Failed to connect to 2800:3f0:4001:806::1005: Network is unreachable

I suppose it has to do somehow with resolving ipv6 adresses.

I saw that on other computers that have a newer version of some linux distro, these requests go fine, so i'm guessing it has to do something with me using ubuntu 10.10, where this problem isn't solved.

I want to be able to curl normally without using the option: -4, what do i have to modify to be able to use curl normally with ipv6 adresses?

share|improve this question
It sounds like you have broken IPv6 connectivity, so you need to figure out why it's broken. Start with some basic information such as ip addr and a description of your network and your ISP. – Michael Hampton Sep 16 '13 at 2:33
further answers can be found on this duplicate question. Regarding duplicate questions please take a look here – bummi Jul 16 '15 at 12:54
See my answer to the same question posted at – mc0e Aug 4 '15 at 15:09
up vote 0 down vote accepted

I have tried connecting to other networks and it worked.

In the mean time i updated my OS to MINT v15 and the problem still stayed.

Actually it even got weirder cause i could curl once, everything would be okay, than i would do it the second time and it would present the same old error.

At last i called my ISP and they set my modem to factory settings and updated the software.

Now everything seems to work fine.

share|improve this answer

If anybody finds this on Google like I did, to fix the issue I just had to tweak my firewall rules for IPv6.

By default I'd blocked everything on the incoming chain - after I added rules to allow established connections, ping requests and anything from localhost IPv6 connections started working!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.