Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having an issue getting Mint 13 LTS to boot on my new machine. I switched off SecureBoot, CSM and Fastboot.

After this I Used USB Installer that comes built into Mint, it ends up with a HPFS/Hidden partition type and is not seen by UEFI bios, therefore I can not select the UEFI boot option. Optical media does not show UEFI as an option on any install media.

So, I then tried UNETBOOTIN, the Usb drive shows up in the list as UEFI supported boot option, attempting to boot this results in it dropping down to grub shell 'grub>' I tired getting it to boot by using the command line, something along the lines of:

grub> set prefix=(hd0,msdos1)/boot/grub
grub> set root=(hd0,msdos1)
grub> configfile /boot/grub/grub.cfg

Here I get the UEFI Style boot menu, but selecting an option drops down and complains about not being able to find vmlinuz and init. Generally this stuff isn't an issue but this system is different.

--EDIT-- I got futher, this is exactly what I did:

set root=(hd0,msdos1)
set prefix=(hd0,msdos1)/boot/grub/x86_64-efi
insmod linux
linux /casper/vmlinuz file=/preseed/mint.seed boot=casper
initrd /casper/initrd.lz
boot

I then get:

error:no suitable mode found.
Booting however
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.