Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 Ultimate. Whenever I click on the "Start" button and then in the search box type anything such as "calc", "notepad", "mstsc", etc., no related program found and nothing is launched when press "Enter".
It always shows

  • Programs
  • Control Panel
  • Documents
  • Microsoft Office Outlook
  • Files

enter image description here

share|improve this question
    
Do you get the desired results from see more results? –  50-3 Sep 16 '13 at 4:34
add comment

2 Answers

You could try rebuilding the Windows Search index.

1. Open Control Panel
2. Click Indexing Options
3. Click Advanced (accept UAC if prompted)
4. Click 'Rebuild'

Note this will take a while to process, and will cause slow hard drive response in the meantime.

share|improve this answer
add comment

I got a fix from the Microsoft support article The "Search programs and files" box does not display search results correctly in Windows 7 and in Windows 2008 R2.
Microsoft has confirmed that this is a problem in the Microsoft products.

WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 How to back up and restore the registry in Windows
To work around this issue, use the following method:

Delete the whole registry subkey

  • Press the Windows logo key + R on your keyboard.
  • In the Run box, type regedit and then press ENTER.
  • Locate the following registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}
  • Right-click this subkey, and then select Delete.
  • Restart the computer.

This workaround did work for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.