Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Even when I visit nosslsearch.google.com I ultimately get redirected to https://www.google.com. Why is this? (I'm not signed in to google, and I'm entering these in the urlbar, not the search plugins.)

I've tried Firefox 23 on both Ubuntu 12.04 and Windows 7, with the same results. I've also tried Chrome on Windows 7 with the same result. I've tried using Firefox in safe mode with all addons disabled, and clean profiles and clean installs of Firefox.

Surely the purpose of the nosslsearch site is to allow non-HTTPS searches, but using the firefox console, I see that it first redirects me to http://www.google.com which subsequently just redirects me to https://www.google.com. Why is it doing this?

(I need non-HTTPS search as HTTPS are blocked)

share|improve this question

marked as duplicate by random Feb 12 at 23:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
BTW do you use nonsslsearch.google.com or nosslsearch.google.com ??? –  Rik Sep 16 '13 at 12:20
    
@Rik sorry that was just a typo, fixed now in question: nosslsearch.google.com –  fpghost Sep 16 '13 at 14:22
1  
@fpghost You can use http://216.239.32.20. That one seems to work. I think Google is messing with some things. 216.239.32.20 is the IP of nosslsearch.google.com. –  Rik Sep 16 '13 at 14:30
2  
You can always add 216.239.32.20 google.com www.google.com in your hosts file so you always get to the http and you never use the https variant. It's not perfect but works. –  Rik Sep 16 '13 at 14:34
    
A current and working solution can be found here: superuser.com/a/727691/78851 –  Lashae Mar 11 at 18:56

1 Answer 1

Normally private browsing will help you to browse without ssl, it will allows you to browse the Internet without saving any information or data about which sites you have visited.

You Can turn off SSl by doing this(assuming you already sign-out of your Google account)

  1. Navigate to Tools → Options

  2. Click on Encryption tab

  3. Remove the checks from next to "Use SSL 3.0" and "Use TLS 1.0."

  4. Click Ok and exit

For firefox 23.0

1.Type about:config

2.Find security.tls.version.max

enter image description here

3.Change the respective values to "0"

security.tls.version.min = 0
security.tls.version.max = 0 

4.Restart the browser to make changes effect.

Normally google uses SSL 3.0 so you can disable and run it.

share|improve this answer
2  
Wouldn't this disabled SSL on all websites? –  Chipperyman Sep 16 '13 at 14:26
    
Tools ---> Options in Firefox 23? –  fpghost Sep 16 '13 at 14:26
    
@fpghost added answer for firefox 23,in firefox 23 the encryption tab is absent,added alternative to it –  BlueBerry - vignesh4303 Sep 16 '13 at 14:37
    
If you want to do it for another browsers you should add a line to the hosts file: 216.239.32.20 google.com www.google.com See geeks.im/how-to-stop-and-disable-google-ssl-https-search/… –  alexsmail Nov 18 '13 at 16:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.