Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had used AD domain before, but the domain was set up already, so I do not have much hands-on experience with setting up everything from scratch, and I am still new to networking side of things, so please bear with me.

Now, I am trying to play the system at home, where I can have the liberty of trying things without worrying about breaking things, but with limited hardware resources.

I have now set up a 2008R2 domain controller with DNS + dhcp. I then tried to join a windows 7 PC to the domain - it failed. I wonder if anyone can shed some light on my set up...

----- here is my set up ------

I have 1 PCs at home, home1. I have set it to use static ID addresses, 192.168.1.15. This is the host computer on which I installed a guest VM - 2008 R2.

Router config:
Router IP: 192.168.1.1
Subnet Mask: 255.255.**248**.0 (will use 192.168.2 network for the AD domain)
DHCP: I did not disable DHCP, but set its IP range to 192.168.1.2 ~ 99, i.e. only dish out IP addresses to network 192.168.1.

I then created a 2008 R2 VM, win-DC.

ID & basic settings
Static ID: 192.168.2.99
subnet mask: 255.255.**252**.0
Default gateway: 192.168.1.1
Preferred DNS server: 127.0.0.1
Alternate DNS servr: 208.67.222.222 (open dns)
Computer name: win-dc
primary DNS suffix of this computer: home.internal
((so after reboot, full computer name is win-dc.home.internal))

DNS settings:

I added DNS role as part of dcpromo. The A record of the server in the forward lookup zone (home.internal) is added, and the reverse one (PTR) record is created. I cannot upload image, but basically in the left pane under reverse lookup zones, I have: 2.168.192-in-addr-arpa. In the left pane, I have 192.168.2.99, a PTR type, point to "win-dc.home.internal."

Added dhcp role. DHCP settings:

A very basic one: ip range : 192.168.2.101 ~ 150

I then created a OU, named PCGroup. Another OU, named AdminStaff.

After all these, I try to connect a windows 7 x64 (client1) to the domain:

I added WDS on this server, so that I can use WDSUtil to add this device using mac address.
Boot up the client1.
Changed it from WORKGROUP to domain "home.internal"

I then got an error: the dns servers used by this computer for name resolution are not responding. This computer is configured to use dns servers with the following ip address: (none)

So I manually configured it to use the above server (ip) as the DNS server, 192.168.2.99.

Tried to join again. Same error, but this time it mentioned the IP addr of my win-dc server.

Note that the client1 is plugged in the router using ethernet cable, not over wifi.

I did notice that it got an IP of 169.234.199.183. It must be getting this IP from the router DHCP . -- I've seen people trying AD domain in home network saying that they disabled DHCP completely. But is this related? Do I must disable DHCP in the router? How can I make client1 join to the AD domain and use DHCP on the server?

Presumably the 1st blocking hurdle is that client1 cannot resolve the server name from ip. But where did I got it wrong?

I have run nslookup on the server:

nslookup 
server win-dc 
set querytype=NS 
.

It seems all right: name is resolved to win-dc.home.internal, IP is 192.168.2.99. When running set querytype=NS followed by '.', I got the list of non-authoritiative answer from name server f.root-servers.net to c.root-servers.net, and ip addresses of them in the reverse resolution.

share|improve this question
    
You need to install the DHCP role on your DC as it will assign an IP address from an address pool to a connecting device. Can you ping the server successfully? –  Yassar Sep 16 '13 at 21:08
    
@yassarikhan786 I did install DHCP role, and made it to dish out 192.168.2.101-150. I only tried ping on the server, since I cannot get client1 to connect to the domain. ping to the win-dc or to its ip all OK. Correct what I just said: I just ping the server from the host PC, worked , too –  user2654478 Sep 16 '13 at 21:12
    
If you have the DHCP role installed you need to disable your routers DHCP service. –  Yassar Sep 16 '13 at 21:15
    
@yassarikhan786 OK. I will try just that. thanks for looking into my post. –  user2654478 Sep 16 '13 at 21:16
    
No problem, glad I could help. –  Yassar Sep 16 '13 at 21:18

1 Answer 1

you need to create the computer object (your vm) before it can join the domain

share|improve this answer
    
I have. I used wdsutil to add the device by MAC address into the domain. I will try disabling router dhcp first. But thanks for the reply. –  user2654478 Sep 17 '13 at 20:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.