Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a very similar problem to this: Is there a way to restart audio without restarting windows 7 computer?

I've got a USB external sound card (Line6 UX1, the older one), the OS is Windows 7 x64.

At a random moment (either when I'm playing a movie or a game) it stops completely.

Variation one: absolutely no sound when playing back anything, but I can edit/playback music without problem through the ASIO drivers (i.e. from Sound Forge).

Variation two: absolutely no sound when playing back anything, and applications using the ASIO driver do not find the external sound card. Flash player freezes all browsers (most ads are now in flash) and also iexplore.exe hungs playing the logoff sound.

I've tried almost everything: getting new drivers, disable/enable sound card through Sound menu (when I trying to disable it, it hangs forever or I cannot even access Sound menu at all!), I have tried even to disable USB management of Power options menu.

My last hope was net stop audiosrv but it went to infinite loop as well (I had enough of it after writing dots on the screen for 5 minutes).

This thing drives me crazy. My hypothesis is that an exception occurs in one of the drivers, that crashes that part of the system. If I could locate that specific process, force kill it and restart, that'd be awesome.

Edit:

I will try to check out this method next time the problem occurs (http://community.spiceworks.com/how_to/show/312-stop-a-hung-service):

  1. query the process ID of the audio service: sc queryex audiosrv
  2. headshot the process dude: taskkill /f /pid [process ID]

I'll update this question if it works, and provide you a batch file.

Edit 2:

With this solution I could restart the Windows Audio service. It looked fine, until I wanted to play anything with audio. Playing goes for a second and stops (either an mp3 in a player or youtube). So the problem is nastier I thought. I'll check out the grounding issue next. Note: Soundcard still works with the ASIO drivers.

share|improve this question
    
bit of a workaround, and I'm a little curious, but I wonder if WASAPI outputs would work when the rest is frozen up. –  Journeyman Geek Sep 17 '13 at 12:09
    
We'll see. On average I get this problem 2 times per week. –  atoth Sep 17 '13 at 12:21
    
The same happened to me and it took time to find a solution. My soundcard, an Icemat Siberia USB Soundcard, had 2 buttons in the driver's GUI that toggled different sized rooms to emulate in the headphones. For what ever reason, when my sound died, all I needed to do was switch between these two modes and sound would come back. For what ever reason, this toggle would reset (in a sense) the driver. I'm sure your driver is vastly different, and although my answer is relatively vague, it may be worth fiddling with your current driver's interface (if there is one) for a setting like this. –  root Oct 2 '13 at 21:00

2 Answers 2

I can suggest you try the following, for what it is worth.

When you open the Device Manager go to View->Devices by connection. After the view changes find the USB HUB where your sound card is plugged in, and try do Disable/Enable it, and see what happens afterwards.

I have used this method to reinitialize USB Stick which I have previously ejected (right click -> eject).

Let me know what you think.

share|improve this answer

Please check the AudioEndPointBuilder and the PlugPlay Services which form the chain of dependency for AudioSrv. Try stop and restart these two services if the situation becomes dire. If PlugPlay service seems affected change the service properties->Recovery->1st failure to "Restart the service" instead of "restart the computer" and then proceed to stop and start that service. Of course if none of these help, examine the possibility of electrical wiring issues (like no proper grounding etc) which I have seen wreak havoc with Plug and Play problem situations. -- Cheers.

share|improve this answer
    
Grounding issues... I never thought of that. Anyway thanks for the tips, I'll check all of them when I encounter the problem again! –  atoth Sep 20 '13 at 13:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.